1 Reply Latest reply on Feb 5, 2018 5:30 PM by Miguel Palacios

    Warning por la Versión del JSF del Weblogic Server 12.2.1.2.0

    3598140

      Hola,

      Esperamos su apoyo, tenemos un servidor weblogic con versión 12.2.1.2.0, en la cual tenemos desplegado un aplicación web y que hace uso  de la versión del JSF 2.2.6; pero el weblogic tiene una la versión de 2.2.8_17 con la cual nos empezó salir un Warning por un componente del JSF, el Warning es el siguiente:

      <Warning> <javax.enterprise.resource.webcontainer.jsf.application.view> <BEA-000000> <Unable to save dynamic action with clientId 'mainForm:j_id-668052436_32c35985_5' because the UIComponent cannot be found>.

      Frente a ello se hizo instalar como biblioteca  en el weblogic la versión 2.2.6 y hacer referencia desde la aplicación, pero el WARNING continuaba, y de igual manera validamos si era la versión de la implementación del JSF desplegando la aplicación en un JBoss 7.0 que tiene la versión 2.2.6.

       

       

      Los tareas que se hicieron para solucionar el problema y no tuvimos exito con ello son los siguientes:

        * Instalar la versión del JSF 2.2.6 como biblioteca.

        * Cambiar la versión del JSF 2.2.8_17 del weblogic del directorio "modules" por uno de 2.2.6, pero seguía haciendo referencia a la versión 2.2.8_17

       

       

      Pregunta:

       

       

      * ¿Hay alguna forma de configurar el weblogic para hacer referencia a la 2.2.6 del JSF a parte de instalar como biblioteca?.

      *¿ Se puede iniciar el Servidor weblogic con la versión 2.2.6 del JSF?

      *¿El warning detallado ya es un error conocido, si es así que configuración se hizo ya sea en el servidor o en la aplicación?

       

       

       

       

      Comentarios:

       

       

      * Por el error que salía empezamos usar Jboss para validarlo y el comportamiento de la aplicación fue existoso, la versión del JSF era 2.2.6 dentro de Jboss EAP 7.0.