4 Replies Latest reply on Mar 16, 2018 6:42 PM by Dude!

    File System

    happy10319

      Hi,

      I added a new disk to my virtual machine.

      Then I ran:

      [root@oamim ~]# mkfs.ext4 /dev/sdb1

      mke2fs 1.43-WIP (20-Jun-2013)

      mkfs.ext4: inode_size (128) * inodes_count (0) too big for a

          filesystem with 0 blocks, specify higher inode_ratio (-i)

          or lower inode count (-N).

       

      [root@oamim ~]# mkdir -p /u02

      [root@oamim ~]# mount /dev/sdb1 /u02

      mount: you must specify the filesystem type

       

      I ignored :"mount: you must specify the filesystem type" message.

      And when reboot I have:

       

      I gave root password and tried to edit /etc/fstab and delete this row:

       

      /dev/sdb1               /u02           ext4    defaults        1 2

       

      Impossible to write into /etc/fstab.

      Thanks for help.

       

      Thanks

        • 1. Re: File System
          Nik

          Hi.

            1, What happens.

              New virtual disk not have any partitions.

              You try  create new FS on undefined partitions and got error.  

                 ..... filesystem with 0 blocks ......

               You ignore it and  try mount device without FS. 

               You again ignore error and configure system for  mount uncorrect device, after this you have error.

           

            2. How resolve.

               You give corect way.  Need remove new line from file /etc/fstab.

               You not show what exactly error you have and for which command.

                Try boot system again and enter root password.

                  - Check that /etc writable:      cp /etc/fstab /etc/fstab.orig

                    In case got error, try remount / :    mount -o rw,remount /      or   mount -o rw,remount /dev/sda1 /

                 

                  -  Delete uncorrect line from /etc/fstab . Use editor or  command:    grep -v  sdb1 fstab.orig > fstab.n

                     Check new file fstab.n :   cat fstab.n

                     Replace wrong file:    cp fstab.n fstab

           

          Reboot system again.

          • 2. Re: File System
            happy10319

            Hi,

            Thank you.

            :

            With mount -o rw,remount / 

             

            I could modify /etc/fstab and now Linux has started.

             

            Now I have a new disk added. Following this article:

            http://www.vitalsofttech.com/add-disk-storage-to-oracle-virtualbox-with-linux/

            I always have run:

             

            [root@oamim ~]# fdisk /dev/sdb

             

            Command (m for help): n

            Command action

               e   extended

               p   primary partition (1-4)

            p

            Partition number (1-4): 1

            First cylinder (1-2610, default 1):

            Using default value 1

            Last cylinder, +cylinders or +size{K,M,G} (1-2610, default 2610):

            Using default value 2610

             

            Command (m for help): w

            The partition table has been altered!

             

            Calling ioctl() to re-read partition table.

            Syncing disks.

             

             

             

            mkfs.ext4 /dev/sdb1

            mkdir -p /u02
            # mount /dev/sdb1 /u02

            And:

            the following added to /etc/fstab

             

            /dev/sdb1               /u02           ext4    defaults        1 2

             

            Anything wrong?

             

            Thanks.

            • 3. Re: File System
              Nik

              Hi.

              First time you skeep fdisk step.

               

              At this moment it's look like ok.

              Try do:

              umount /u02

                mount /u02

               

              It's allow check  that fstab is correct.

              Do not ignore any error messages.

              After this you can reboot system.

               

              Regards,

              Nik

              • 4. Re: File System
                Dude!

                Before you restart the system, you can simply use "mount -a" to verify /etc/fstab is working.