0 Replies Latest reply on Mar 27, 2018 7:09 AM by 1002933

    Apps R12 Integrated SOA Gateway /SOA Provider/pl sql/wf_notification/respond

    1002933

      Hello All,

       

      Apps EBS : R12.1.3

      Database: 11g

       

      Facing some issue while running the /SOA Provider/pl sql/wf_notification/respond SOAP webservice.

      Testing Tool: SOAP UI

       

      Request:

      <soapenv:Envelope xmlns:res="http://xmlns.oracle.com/apps/owf/soaprovider/plsql/wf_notification/respond/" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wf="http://xmlns.oracle.com/apps/owf/soaprovider/plsql/wf_notification/">

         <soapenv:Header>

            <wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">

               <wsse:UsernameToken wsu:Id="UsernameToken-93C1135984D5CFDEAF152212674387010">

                  <wsse:Username>SYSADMIN</wsse:Username>

                  <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">123456</wsse:Password>

                  <wsse:Nonce EncodingType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#Base64Binary">wWCmJAhuekQWtIIWtGpe4w==</wsse:Nonce>

                  <wsu:Created>2018-03-27T04:59:03.870Z</wsu:Created>

               </wsse:UsernameToken>

            </wsse:Security>

            <wf:SOAHeader/>

         </soapenv:Header>

         <soapenv:Body>

            <res:InputParameters>

               <!--Optional:-->

               <res:NID>9766716</res:NID>

               <!--Optional:-->

               <res:RESPOND_COMMENT>TEST</res:RESPOND_COMMENT>

               <res:RESPONDER>TEST_APPROVER</res:RESPONDER>

               <!--Optional:-->

               <res:ACTION_SOURCE>APPROVED</res:ACTION_SOURCE>

            </res:InputParameters>

         </soapenv:Body>

      </soapenv:Envelope>

       

       

      It is running without any error, but the notification is not approved.

      Its creating one more notification for the same user as pending.

       

      Kindly suggest.

       

      Regards,

      Afzal.