0 返信 最新の回答 日時: Apr 4, 2018 2:35 AM ユーザー:3683312

    OracleDB12cR2へのJDBC接続について

    3683312

      <主な環境情報>

      DB:Oracle 12cR2

      MW:JDK1.4でコンパイルされたJar

      JRE環境:8

      概要:JRE8環境上で、JDK1.4で作られたJarを使って、Oracle12cR2へ接続する。

       

      いつもありがとうございます。

      以下2点の質問です。

       

      <Q1>

      下記OracleのJDBCにかんする情報公開ページにて

      https://docs.oracle.com/cd/E49329_01/java.121/b71308/overvw.htm#BABCHIGI

      サポートされるJDKおよびJDBCのバージョン
      Oracle Database 12cリリース1 (12.1)では、JDBCドライバはすべてJDK 6.0と互換性を持ちます。JDBC ThinドライバとOCIドライバは、JDK 6もサポートします。
      6.0より前のJDKのバージョンはいずれも、もうサポートされていません。JDK 6.0とJDK 7のサポートは、それぞれojdbc6.jarファイルとojdbc7.jarファイルによって提供されます。

       

      上記対象外となるのはJDK6より前に作成(コンパイル)したアプリケーションという意味でしょうか。

      もしくは、JRE6より前で動作させようとした場合、の意味でしょうか。

       

      <Q2>

      下記のOracleドキュメント上では「Oracle12cR1では、JDK1.4以降の標準JDBC3.0をサポートしている、、」という記述があるのですが

      JDK1.4のアプリケーションでDB「Oracle12cR2」への接続が可能なJDBCドライバーはございませんでしょうか。

       

      https://docs.oracle.com/en/database/oracle/oracle-database/12.2/jjdbc/JDBC-standards-support.html#GUID-0B52F2F0-AEA8-490…

      3.2 Support for JDBC 3.0 Standard

      Oracle Database 12c Release 1 JDBC drivers provide support for Standard JDBC 3.0 features through JDK 1.4 and later versions. The following table lists the JDBC 3.0 features supported by this release of Oracle JDBC drivers and gives references to a detailed discussion of each feature.

       

       

      ご存知であれば、ご回答をお願いいたします。