3 Replies Latest reply on Apr 6, 2018 7:38 AM by Joel Acha

    OBIEE 12c 12.2.1.3.0 - Is Microsoft Edge browser 40+ and/or IE11 not supported?

    Chris|ger

      Hello,

       

      I've been using OBIEE 12c (12.2.1.3.0) and stumbled across poor microsoft browser support, when logging in (Edge browser - Vers. 40.15063.674.0) and creating answers (Internet Explorer 11 Vers. 11.966.15063.0).

       

      According to Oracle Fusion Middleware Certification matrix, both browsers should be fully supported by all 12.2.1.3.0 FMW Products, which ofcourse includes OBIEE 12.2.1.3.0

      Link (xlsx): http://www.oracle.com/technetwork/middleware/fmw-122130-certmatrix-3867828.xlsx

       

      1.) unable to create Answers using IE11

      Trying to create answers, there are several buttons, which do not react to mouseclicks.

       

      For example i am unable to directly edit views from compound layout by clicking "edit" in the views header panel. Instead, i have to use the edit link in the views panel at the bottom. While this might be a temporarily workaround, there are more serious problems with IE11:

       

      Editing Views, i am unable to make changes and leave that screen because both buttons "done" and "revert" do not react to mouseclicks. It's impossible to configure table views, without beeing able to save changes.

      Adding total amounts for example is impossible too, as that links also do not work.

      All in all, OBIEE 12.2.1.3.0 seems to be broken using IE 11.

       

      2.) unable to login using Edge 40ü+

      Using Edge i am unable to login into analytics and VA. So analytics loginscreen appears as usual and i am able to enter weblogic credentials. This is then followed by a loading screen, saying login is beeing processed. But nothing ever happens. So login process never finishes.

       

      Calling Visual Analyzer, i am redirected to a blank page. VA login screen never appears.

       

       

      reproducing that behavior using a fresh BI 12.2.1.3.0 install with sampleapplite

      First i thought, this might be a problem because of our custom style deployed (based on Alta), where oracle logo has been exchanged.

       

      So i've done a complete fresh installation on another server and configured sampleapp lite to be deployed when the domain was initially configured.

       

      But both problems still exist in sampleapplite. So I am asking myself, whether oracle has fully tested both browsers when they handed out their certification matrix.

       

      This leads to my question, whether Edge and IE 11 are officially supported by Oracle.

       

      Have you ever experienced that behavior in BI 12.2.1.3.0?

       

       

      Using chrome/firefox/...

      Both Chrome and Firefox work as intended and do not show such a behavior. So one might ask, why I am unable to use them. The point is: I already use Firefox when developing answers and dashboards. So this might not be a direct problem for me/my colleagues. But the main problem is, we have several OBIEE 11g customers and would like to upgrade them from OBIEE 11g to OBIEE 12.2.1.3.0.

       

      Some of them are kind of forced to use IE/Edge as there might be lots of different tools they have to use and their IT might not allow to install another browser. So we can only propose to use another browser.

       

      Poor IE/Edge browser support could be a kind of showstopper then.

       

      Regards

      Christian

        • 1. Re: OBIEE 12c 12.2.1.3.0 - Is Microsoft Edge browser 40+ and/or IE11 not supported?
          Joel Acha

          In the Certification Matrix, on the Browser tab there is some text which states:

           

           

          ALL includes the following products: Fusion Middleware 12c Products, with the Exception of: 

             Oracle Data Integrator (Agent, Studio), Oracle GoldenGate Studio, Oracle WebCenter Sites Explorer, Oracle WebCenter Sites Developer Tools, Oracle Enterprise Data Quality Address Verification, Oracle Business Intelligence Enterprise Edition (Oracle BI Server and Admin (BI Server, BI Administration Tool))

          1 person found this helpful
          • 2. Re: OBIEE 12c 12.2.1.3.0 - Is Microsoft Edge browser 40+ and/or IE11 not supported?
            Chris|ger

            Hi Joel,

            thank you for that notice. That's quite embarrassing

             

            I guess, my eyes just wanted it to be included by the term 'ALL' when I read that certification document.

             

             

            Nevertheless I intensified my search for more information on the topic and followed the links provided in the certification matrix document on the tab 'Menu' which states:

            "For complete Fusion Middleware, OBI EE, and EPM products certifications, refer to http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html "

             

            In my opinion this statement is a bit misleading now, as you won't find special certifications for OBIEE 12c itself on that page.

             

            You find another link to Oracle Browser Support Policy though, which is the next link I followed:

            Oracle Software Web Browser Support Policy

             

            Here Oracle states more precisely how the will support major browser releases of Microsoft Browsers, Firefox, Chrome and Safari "In the case where feature parity is not consistent for the same browser version across platforms and devices, those features are only supported by Oracle to the extent that the vendor has enabled.

             

            Oracle Software will support new browser releases in accordance with the following schedule and distribution methods:

            1. For new major releases of Mozilla Firefox and Google Chrome, Oracle will provide support with all versions of Oracle software that are under active support immediately upon general availability of the browser. Reference Oracle Error Correction Policy(ECP) support documentation for specific product support information. Note 1290894.1, Error Correction Support Dates for Oracle Fusion Middleware 11g (11.1.1/11.1.2) and Note 209768.1, Database, FMW, Enterprise Manager, TimesTen In-Memory Database, and OCS Software Error Correction Support Policy.
              • Any issues encountered that will require Oracle software fixes, will be fixed and provided via the established patching process for the specific product requiring the fix.
            2. For new major releases of Microsoft Browser and Apple Safari, Oracle will provide support with all versions of Oracle software that are under active support within nine months of general availability of the browser. Oracle will stop supporting a browser version from a vendor with all supported versions of Oracle software immediately upon the vendor de-supporting that browser.
              • Oracle will issue an appropriate PSU or patch set/RUP for each supported version of Oracle software in support of this browser version.
            3. Oracle will stop supporting a browser version from a vendor with all supported versions of Oracle software immediately upon the vendor de-supporting that browser.
            4. For new Oracle Software product releases:
              • For On-Premise products Oracle will certify the latest version of each of the four major browsers and one back (n-1) at the time that the Oracle on-premise software is released for General Availability, as long as the n-1 browser is supported by the vendor.
              • For Software as a Service(SaaS) and Platform as a Service(PaaS) products, Oracle will certify the latest version of each of the four major browsers at the time that the Oracle SaaS or PaaS software is released for General Availability."

             

             

            So I guess, I should go on and raise an SR about it on MOS.

            • 3. Re: OBIEE 12c 12.2.1.3.0 - Is Microsoft Edge browser 40+ and/or IE11 not supported?
              Joel Acha

              You would expect "ALL" to actually mean "ALL"!