9 Replies Latest reply on Apr 10, 2018 2:36 PM by Sergio-Oracle

    RHEL 5 to OEL

    Eric Schrauth

      Have a Red Hat Enterprise Linux Server release 5.6 (Tikanga) server that I want to switch over to OEL.  When I try to install anything it gives me:

      There was an error communicating with RHN.

      RHN Satellite or RHN Classic support will be disabled.

      Error communicating with server. The message was:

       

       

      Error Class Code: 6001

      Error Class Info:

           RHN is in the process of being decommissioned and systems are no longer able to receive updates or make use of any RHN services.

           Please see https://access.redhat.com/articles/2979901 for more info.

       

      Does anyone know what my options are?  Thanks in advance!

       

      Eric

        • 1. Re: RHEL 5 to OEL
          Dude!

          Nobody here has a crystal ball to look over your shoulder to see what you are doing.

           

          How did you switch from RHEL to Oracle Linux? Do you have a subscription for Oracle ULN or do you wish to access the public software repositories (oracle public yum)?

          • 2. Re: RHEL 5 to OEL
            Eric Schrauth

            Sorry if I didn't supply enough information.

             

            I have not switched to Oracle Linux yet.  It is still RHEL.  I have a subscription but dont know how to switch the RHEL machine to use it.

            • 3. Re: RHEL 5 to OEL
              Dude!

              I suggest you review the following:

               

              https://linux.oracle.com/switch.html

               

              And btw, it's no longer called OEL since 2011. The product has been rebranded to Oracle Linux, or OL. People often find it irritating when they read OEL in the Oracle Linux forum.

              • 4. Re: RHEL 5 to OEL
                Eric Schrauth

                Sorry if I use the wrong acronym. 

                 

                I read the instructions on the web page that you reference but when I execute the command I get the following:

                 

                [root@coma tmp]# rpm -Uvh up2date-5.10.1-40.14.*.rpm

                warning: up2date-5.10.1-40.14.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 1e5e0159

                error: Failed dependencies:

                        rhn-client-tools = 0.4.20-46.el5 is needed by (installed) rhn-setup-gnome-0.4.20-46.el5.noarch

                        rhn-setup = 0.4.20-46.el5 is needed by (installed) rhn-setup-gnome-0.4.20-46.el5.noarch

                 

                If I try to install rhn-client-tools or rhn-setup I get the same error as I first posted.

                • 5. Re: RHEL 5 to OEL
                  Dude!

                  Did you follow the instructions? They look different. It is sometimes necessary to install multiple packages in one command. e.g.:

                   

                  # wget http://linux-update.oracle.com/rpms/up2date-5.10.1-40.14.el5.x86_64.rpm
                  # wget http://linux-update.oracle.com/rpms/up2date-gnome-5.10.1-40.14.el5.x86_64.rpm

                  # rpm -Uvh up2date-5.10.1-40.14.*.rpm up2date-gnome-5.10.1-40.14.*.rpm

                   

                  • 6. Re: RHEL 5 to OEL
                    Tommy.Reynolds-Oracle

                    Hi,

                     

                    When you try to update one RPM and get those "failed dependencies" and you try to install them and you get a message your first RPM is needed, then you have a group of RPM packages in a circular dependence.  The trick is to update them all at once:

                     

                    # rpm -Uvh *.rpm
                    

                     

                    All the RPM packages named on the command line are updated in one atomic operation so you do not get that circular problem.  On most other commands it does not matter if you update one package at a time or all together but rpm(8) needs to be more picky so that the package database is always consistent.

                    1 person found this helpful
                    • 7. Re: RHEL 5 to OEL
                      Eric Schrauth

                      Thanks Tommy!  That seems to have worked! 

                      • 8. Re: RHEL 5 to OEL
                        Eric Schrauth

                        After following the rest of the instructions on https://linux.oracle.com/switch.html, I get an Already Registered window when I do up2date --register.  Is this normal?

                        • 9. Re: RHEL 5 to OEL
                          Sergio-Oracle

                          Try updating the UUID in /etc/sysconfig/rhn/up2date with a new value from this command:

                           

                          uuidgen -t