0 Replies Latest reply on Apr 19, 2018 1:12 PM by user9062184

    Solaris 11.4 beta to Solaris 11.4 (11.4.0.0.1.3.0) - zpool import kernel panic host

    user9062184

      Hi there. I've run argound on the b3 upgade.

       

      As follows.

       

      Machine:             4-year-old Intel 115x socket (4 core), 16GB memory, DDR3. QLogic FC HBA installed. Nothing special about it. Has run Solaris 11.2, 11.3….for a long time.

      Storage:               4 * WD RED 6TB NAS drives in a RAIDZ1. Accidentally added an internal SSD (m.2 form factor) and a couple of other drives to the vdev the other day. Was meant to zpool attach cache but actually zpool add’ed. Stupid me. No harm done, really. Ish.

       

      1. Upgraded from 11.3 quite a while ago to the 11.4 beta (initial release). Things seemed ok.
      2. Decided the other day, given things seemed quite stable, to zpool upgrade rpool and zpool upgrade samarium (my RAIDz1 storage pool)
      3. Things still seemed ok.
      4. Did a pkg update -v –accept two days ago when B3 came out for 11.4. Looked good on upgrade. No errors in updating boot archive or the install procedure.
      5. “reboot”
      6. Box never came back and went into constant reboot cycle.

       

      Kernel panic whenever storage pool is connected, as following screenshots illustrate. See attached in link:

       

      https://cloudstor.aarnet.edu.au/plus/s/JJpJ5b8y0gzHtqX

       

      Also, I’ve uploaded a core dump I got out of the machine, from the same link.

       

      From the blurry shots I’ve got, it complains about a fast reboot panic of some kind – but this only occurs if I plug the raidz1 vdev pool members in. If those big SATA drives/other SSD’s and odds and ends are not plugged into the bus, the box comes up fine. Tried single user. Tried to bring it up then zpool import…and upon zpool import, same kernel panic and stack trace.

       

      Trying to import the pool (version 43…) into an older BE behaves the same way – with a kernel panic and spin out.

       

      Not sure what to do at this point. I’ll be sad if I’ve lost my poor old storage pool! It’s worn through so many upgrades and spare outs! Was hoping to get to pool version 44 so I could remove the devices I put there in error….but I never made it!

       

      Thanks!