6 Replies Latest reply on Apr 27, 2018 10:20 AM by Mark.Thompson

    SQL Developer will not start on Linux

    Mark.Thompson

      I downloaded SQL Developer 18.1.0.095.1630.1.noarch.rpm and installed it into an Oracle Cloud VM this morning, as follows:

       

      rpm -Uhv sqldeveloper-18.1.0.095.1630-1.noarch.rpm

       

      It appeared to install just fine.

       

      Now I want to run it.

       

      sudo su - oracle

      cd /opt/sqldeveloper

      ./sqldeveloper.sh

       

      Upon execution of the shell script, I was prompted for the location of my JDK, which is /usr/java/jdk1.8.0_141.  I entered that, and then... nothing.  The system just did absolutely nothing.  After about 30 minutes, I hit ctrl-c to interrupt.

       

      The installer said that the path specified for the JDK would be stored in /u01/app/oracle/tools/home/oracle/.sqldeveloper/18.1.0/product.conf, so I looked for that file.  It does not exist.  In fact, the path /u01/app/oracle/tools/home/oracle is empty - no directories or files.

       

      After using ctrl+c to cancel, and looking for the non-existent path, I tried to execute the shell script again.  This time, I am not even asked for the path to the JDK.  The system just does absolutely nothing again.

       

      I reconnected to the machine in a new putty session, and tried running ./sqldeveloper.sh as the user opc.  I was told that the path to the JDK would be /home/opc/.sqldeveloper/18.1.0/product.conf.  Once again, after entering the /usr/java/jdk1.8.0_141 at the prompt, the system did nothing for several minutes, until I again executed Ctrl+C to interrupt.  A search of /home/opc showed an empty directory.

       

      At this point, it doesn't matter whether I try to run the shell script when signed in as opc, or as oracle, or as the King of Siam.  I am not prompted for the location of the JDK, and nothing happens.

       

      What step(s) am I missing?