1 2 3 Назад Вперед 32 Ответы Последний ответ: 30.05.2018 12:34, автор: 996872

    Essbase patch update

    996872

      Hi All,

       

      I got below error when trying to zoom in a column in smart view.

      Essbase error (1013295) .Server request fails with error code 1 .

      Looks like I need to install a patch for this as per oracle . (Patch for Analytical service provider)

      I am on 11.1.2.4.011 version.

      The read me suggests that I need to update Essbase as well.

      Can someone please help me here what are the things I need to install and the procedure.

       

      I will be doing this very first time , so please help me here.

       

      - Many Thanks

        • 1. Re: Essbase patch update
          TimG

          You need to download the patches (for your operating system) from Oracle Support which I assume you have already done. Detailed instructions for applying the patch (using the opatch utility) are contained in the patch ReadMe file.

           

          If this is a production environment make sure you have a good backup.

          • 2. Re: Essbase patch update
            JohnGoodwin

            If you are applying patches then each of the Essbase products should be on the same patch version unless started otherwise in the readme.

            If you want a list of the latest Essbase product patches you should apply then go to https://blogs.oracle.com/proactivesupportepm/psu_essbase_11124023

            The readme should be clear enough on the process you should follow.

             

            Cheers

             

            John

            • 3. Re: Essbase patch update
              TechWUB

              Hi,

               

              As John Suggested, the Read me doc should be sufficient. However, before you proceed Stop all the EPM Services and take a back up of OPatch folder.      

               

              Also confirm if this a distributed environment.

              • 4. Re: Essbase patch update
                996872

                Hi,

                 

                Yes it's a distributed environment. One server for Essbase and another for Foundation services.

                 

                -Thanks

                • 5. Re: Essbase patch update
                  JohnGoodwin

                  Compile a list of the required patches, I have provided a link to the Essbase related ones, go through the ReadMe of each patch carefully and carry out all steps.

                  If your have a two servers then then the simplest way is to apply the patches to both servers, if the patch is not required it will not apply.

                  • 6. Re: Essbase patch update
                    ManojPavan-Oracle

                    Hello,

                     

                    Although its not mandatory it is always recommended to have EAS, APS and ESSBASE on the same patch level.

                     

                    As you are saying distributed installation,

                     

                    If EAS is installed on a different server than Essbase you need to apply ESSBASE RTC patch on EAS server as well.

                    • 7. Re: Essbase patch update
                      996872

                      Ok, thank you all for helping me on this.

                      So I will apply this patch 11.1.2.4.013 on Essbase, EAS, APS as per below oracle link.

                      https://blogs.oracle.com/proactivesupportepm/patch-set-update-:-hyperion-essbase-11124013-is-available

                      I have downloaded the patch for Essbase and on Read me I found the below.

                       

                      The section includes important information about applying this patch for Essbase.

                      Component

                      Patch ID

                      Essbase Client MSI (Windows)

                      24589681

                      Essbase Client (OPatch)

                      24589669

                      Runtime Client

                      24589678

                      Essbase Server

                      24589660

                       

                      I have a little doubt here.What does this Essbase client(OPatch) means . Do I need to to install this as well.

                      My environment is Windows server 2012.

                       

                       

                      Appreciate for any help.

                      Thank you !

                      • 8. Re: Essbase patch update
                        JohnGoodwin

                        If you are going to apply patches then I recommend considering the latest set which is 11.1.2.4.023 as lots have bugs have been addressed between 013 and 023.

                        Don't worry about the client, focus on Essbase Server, RTC, APS and EAS, Studio (if you have it)

                        • 9. Re: Essbase patch update
                          996872

                          Thank you so much John, I will accept you recommendation and apply the latest patch only.

                          What are the things I need to take back up before I apply the patch.

                           

                           

                          -Many Thanks

                          • 10. Re: Essbase patch update
                            JohnGoodwin

                            I assume you are already taking backups as part of a backup strategy, make sure you have backups of the Essbase apps, sec file, such as a file system backup.

                            1 пользователь считает эту информацию полезной
                            • 11. Re: Essbase patch update
                              996872

                              Hi John,

                               

                              I found some issues in .23 patch (In Essbase Read me) which we use in our Applications.

                              Can you please suggest any stable release.

                               

                              - Many Thanks

                               

                               

                              Dim build setting "allow move" is not allowed

                              Dim build setting "allow move" (for moving a member to another parent) is
                              not allowed, regardless of the uniqueness defined at the generation level.

                              (26528652)

                              Issue with @PARENTVAL() Function

                              When a calculation formula associated with sparse member assigns a dynamic parent value to a stored child member through @PARENTVAL it may produce a #Missing result. To get the correct result the formula needs to be executed attaching to a dense member.

                              (24481074)

                              Essbase Administration Services Server Can Terminate Abnormally After Updating the Outline

                              If EAS server crashes upon "Update Outline" and if the JRE used is jrockit, add the option -Xss1m in setCustomParamsEssbaseAdminServices.sh at< EPM_ORACLE_INSTANCE>/bin/deploymentScripts>.
                              The default size of a thread stack in jrockit is 320K for win64 and 1M for linux64. So, set the -Xss value accordingly. 

                              (22985660)

                              • 12. Re: Essbase patch update
                                JohnGoodwin

                                There are always going to be issues with any patch release, that is the way it goes.

                                Usually patches are installed to a dev/test environment first and regression testing is carried out before deciding to apply to a prod environment.

                                Patches can always be rolled back.

                                The choice is yours which patch release you go for.

                                • 13. Re: Essbase patch update
                                  TechWUB

                                  Hi,

                                   

                                  Please check the read me of the lower patches, if the known issues of Patch .023v are concerning to your environment.

                                   

                                  However, as suggested it is always better to be on the higher patch version of any component.

                                  As you are on distributed environment, please let us know, what component is installed on which server.  We can suggest you if required.

                                   

                                  - Adding on  -

                                  If you have to apply the patches on more than one servers then apply the patches servers, if the patch is not required on server it will not apply on that server.

                                   

                                  OPatch is the mainly the folder to be backed up. The read me contains the details of How to Roll back the applied patch please check.

                                   

                                  Thanks,

                                  TechWUB

                                   

                                   

                                  • 14. Re: Essbase patch update
                                    996872

                                    Hi John,

                                     

                                    After going through all patch Read me docs I decided to choose patch .013.

                                    When I read the EAS patch doc , it's written that .11 is not supported and I am  on 11.1.2.3.4.011 version.

                                    I went through all patch docs but did not find any EAS patch supporting EAS .11.

                                     

                                    Can you please suggest or  am I doing something wrong .

                                     

                                    Supported Paths to this Patch

                                    You can apply this patch to the following releases:

                                    • 11.1.2.4.000
                                    • 11.1.2.4.001
                                    • 11.1.2.4.002
                                    • 11.1.2.4.003
                                    • 11.1.2.4.004
                                    • 11.1.2.4.005
                                    • 11.1.2.4.008
                                    • 11.1.2.4.010
                                    • 11.1.2.4.012
                                    1 2 3 Назад Вперед