2 Replies Latest reply on Apr 30, 2018 7:52 AM by happy10319

    VERR_INVALID_PARAMETER when Cloning

    happy10319

      Hi,

      VirtualBox 5.2.8 on Windows 7

      When cloning I receive:

       

      Could not create the clone medium 'C:\Users\pc\VirtualBox VMs\Clone ***.vdi' (VERR_INVALID_PARAMETER).

       

      Code d'erreur : VBOX_E_FILE_ERROR (0x80BB0004)

      Composant : MediumWrap

      Interface : IMedium {4afe423b-43e0-e9d0-82e8-ceb307940dda}

       

      Here is what I found in VBoxSVC.log

       

      00:15:03.925670    ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={85cd948e-a71f-4289-281e-0ca7ad48cd89} aComponent={MachineWrap} aText={The object functionality is limited}, preserve=false aResultDetail=0
      00:15:03.925670    ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={85cd948e-a71f-4289-281e-0ca7ad48cd89} aComponent={MachineWrap} aText={The object functionality is limited}, preserve=false aResultDetail=0

      00:20:09.800688 createClone ERROR [COM]: aRC=VBOX_E_FILE_ERROR (0x80bb0004) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Could not create the clone medium 'C:\Users\pc\VirtualBox VMs\NEWMYVM\NEWMYVM.vdi' (VERR_INVALID_PARAMETER)}, preserve=false aResultDetail=0

       

      Is there any limitation for size?

      vdi file is 48Gb.

      Any idea?

      Which parameter? Where to find it?

       

      Thanks.

        • 1. Re: VERR_INVALID_PARAMETER when Cloning
          happy10319

          Finally I did the following:

          C:\Program Files\Oracle\VirtualBox>VBoxManage clonehd "C:\Users\pc\VirtualBox VMs\MYVM\MYVM.vdi" "C:\Users\pc\VirtualBox VMs\NEWMYVM\NEWMYVM.vdi"

          0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

          Clone medium created in format 'VDI'. UUID: 5d9a925e-1436-4157-b44a-b13ca533b39c

           

          And then created a new VM.

          It seemed working.

          The command line finished on success. And I created a new machine. But when I started the machine and verified file systems some intallation folders where missing!!!

           

          Any help?

          • 2. Re: VERR_INVALID_PARAMETER when Cloning
            happy10319

            Finally:

            I ran cloner from GUI. I chose all snapshots. And cloning worked well. File systems are there.

            Regards.