7 Replies Latest reply on Jun 8, 2018 2:57 PM by Robert Angel

    After 12.2.1.4.0 upgrade EM Application Role assignments hangs when selecting role

    Polaiah-Oracle

      Hello,

       

      After upgrading from 12.2.1.2.0 to 12.2.1.4.0, we are experiencing issues when assigning users to Application Roles in EM.

      After selecting a role the system hangs for a long time (sometimes over 10min) before we are able to start assigning users.

       

      bi_server1.log
      ===========================================
      ####<May 23, 2018 2:18:30,563 PM MDT> <Error> <HTTP> <usaglbobid2> <bi_server1> <[STANDBY] ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <d6470765-3af0-4ebc-b921-5759162658a6-00000009> <1527106710563> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-101165> <Could not load user defined filter in web.xml: oracle.lbs.util.ProxySecurityFilter.
      java.lang.RuntimeException: Couldn't get system user credentials.
      at oracle.lbs.util.ProxySecurityFilter.init(ProxySecurityFilter.java:93)
      at weblogic.servlet.internal.FilterManager$FilterInitAction.run(FilterManager.java:400)
      at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:326)
      at weblogic.security.service.SecurityManager.runAsForUserCode(SecurityManager.java:197)
      at weblogic.servlet.provider.WlsSecurityProvider.runAsForUserCode(WlsSecurityProvider.java:203)
      at weblogic.servlet.provider.WlsSubjectHandle.run(WlsSubjectHandle.java:71)
      at weblogic.servlet.internal.FilterManager.initFilter(FilterManager.java:130)
      at weblogic.servlet.internal.FilterManager.loadFilter(FilterManager.java:92)
      at weblogic.servlet.internal.FilterManager.preloadFilters(FilterManager.java:72)
      at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1928)
      at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3101)

      .

      .

      .

      ####<May 23, 2018 2:22:43,832 PM MDT> <Warning> <oracle.igf.ovd> <usaglbobid2> <AdminServer> <[ACTIVE] ExecuteThread: '26' for queue: 'weblogic.kernel.Default (self-tuning)'> <weblogic> <> <40c77aef-c03d-40de-b072-56aadbc762c9-0000009b> <1527106963832> <[severity-value: 16] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <IGF-00008> <Operations error: entity= op=search mesg=Operations Error No LDAP connection available to process request for DN: CN=Service\, ......,DC=com. >

      ####<May 23, 2018 2:22:53,837 PM MDT> <Warning> <oracle.igf.ovd> <usaglbobid2> <AdminServer> <[ACTIVE] ExecuteThread: '26' for queue: 'weblogic.kernel.Default (self-tuning)'> <weblogic> <> <40c77aef-c03d-40de-b072-56aadbc762c9-0000009b> <1527106973837> <[severity-value: 16] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <IGF-00008> <Operations error: entity= op=search mesg=Operations Error No LDAP connection available to process request for DN: CN=Service\, ......,DC=com. >

      .

      .

      ####<May 23, 2018 2:47:19,955 PM MDT> <Error> <WebLogicServer> <usaglbobid2> <AdminServer> <[ACTIVE] ExecuteThread: '62' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <40c77aef-c03d-40de-b072-56aadbc762c9-000000b2> <1527108439955> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000337> <[STUCK] ExecuteThread: '26' for queue: 'weblogic.kernel.Default (self-tuning)' has been busy for "717" seconds working on the request "Http Request Information: weblogic.servlet.internal.ServletRequestImpl@78ece71f[POST /em/faces/as/security/appRolesMain]
      ", which is more than the configured time (StuckThreadMaxTime) of "600" seconds in "server-failure-trigger". Stack trace:
      sun.misc.Unsafe.park(Native Method)

       

      Thank you,

      Polaiah