1 2 Previous Next 20 Replies Latest reply on Jun 11, 2018 6:07 PM by Vadim Tropashko-Oracle

    Insight completion not working

    ANNEC

      My auto insight completion not working on 4.2 version.

      Then I download version 18.1. Same thing, not working.

       

      I also tried to use control+space, nothing showed.

       

      How can I fix it?

      I checked in preferences- completion Insight, all the check boxes are checked.  Popup speed set to 0.3 seconds, tried .6 seconds not work either.

      No pop up showed.

       

      Thanks

        • 1. Re: Insight completion not working
          thatJeffSmith-Oracle

          We can't help you if you won't show us what you're doing.

          • 2. Re: Insight completion not working
            ANNEC

            For example:

             

            If I want to:

             

            select          from employees;

             

            I tried to get a list of table columns, but it does not pop up, I used control+space, it does not work either.

             

            I also tried this way:

             

            select e.    from employees  e

            When I type e. the columns does not show up.

            Also use either space or control+space , no columns of list shown.

             

             

            Thanks,

            • 3. Re: Insight completion not working
              thatJeffSmith-Oracle

              What is employees?

               

              Who does it belong to?

               

              Who are you logged in as?

               

              I'm using the feature here, invoking with ctrl+space

              You can see what we're doing to get the column list in the Statements panel

               

              1127HR18SELECT 'COLUMN' type, owner, table_name object_name, column_name, column_id, data_type FROM sys.all_tab_cols WHERE hidden_column = 'NO' and rownum <=50 and owner = ? and table_name = ? 1="HR", 2="EMPLOYEES"
              • 4. Re: Insight completion not working
                ANNEC

                Sorry, I just made an example generically.

                Let me use a table in our database to make an example.

                 

                I login as PS user/schema, and students is a table:

                 

                Select  from ps.students;

                 

                The columns lists not showing up after I type above, after select I use control+ space, nothing shows.

                • 5. Re: Insight completion not working
                  thatJeffSmith-Oracle

                  See the query we use to grab a column list. Run it for your scenario. What comes back.

                   

                  Also, what version of Oracle are your connected to?

                  • 6. Re: Insight completion not working

                    Please reread what you were first told.

                     

                    SHOW US (don't just tell us):

                     

                    1. WHAT you do

                    2. HOW you do it

                    3. WHAT results you get

                     

                    We need to SEE IT.

                    • 7. Re: Insight completion not working
                      ANNEC

                      Jeff, here is the result of the query, there are more in the list, I only copied 27 rows. I am using Oracle 12c on windows 2016

                      • 8. Re: Insight completion not working
                        Glen Conway

                        Using the standard HR schema on 18.1, if I type

                        select       from employees;

                        then press Ctrl+Space

                        1. After the "t" in "select", I see a list of choices, each beginning with SELECT

                        2. After any blank space following the "t" in "select", I see the list of column names for the employees table.

                        3. After the semi-colon following "employees", I see nothing.

                         

                        Is (3) what you are trying?

                        • 9. Re: Insight completion not working
                          ANNEC

                          For 1, 2, 3 I tried, nothing shows up.

                          One time it comes out when I type t in select, it comes out a list once, but I cannot reproduce it.

                          Also tried after I typed select   from employee; then I put the cursor back to space after select and use control space, nothing happens.

                           

                          I thought I may try on my older computer with version 4.1.5, and I tried above bolded statement, it worked. and it worked also for 1, 2 you mentioned.

                          I changed to 0.6 seconds instead of 0.3 seconds in the setting. Now on my new computer I can see list after type select  or employees.

                          But I can not reproduce the bolded above statement in the new computer, but I can do on old computer with old version of SQL developer.

                          • 10. Re: Insight completion not working
                            Glen Conway

                            I guess the Completion Insight feature can be balky at times, although perhaps it balks more for you than others.  Try

                            select * from employees;

                            put the cursor before the asterisk, then Ctrl+Space. That seems a bit more consistent for me.

                            • 11. Re: Insight completion not working
                              thatJeffSmith-Oracle

                              the auto-completion will never activate b/c you have more than 10 columns...it hides itself by the default preferences

                               

                              ctrl+spacebar should always work

                               

                              now...show us your editor

                               

                              if you have invalid/incomplete code around your query, that can confuse the parser

                               

                              So, i need to know what exactly is in your sql worksheet

                              1 person found this helpful
                              • 12. Re: Insight completion not working
                                ANNEC

                                 

                                Here is my screenshot. After I put my cursor after select and use control+space, nothing happens.

                                • 13. Re: Insight completion not working
                                  Glen Conway

                                  As usual, Jeff is correct:

                                  Capture.JPG

                                  Edit:

                                  So you should either be able to increase the match value, or type the leading characters of a column name before the Ctrl+Space.

                                  Except that rule is not exactly right either, the match value does not seem to apply for Ctrl+Space.

                                   

                                  Moreover, playing around with reducing the match value, and using both Ctrl+Space and the automatic pop-up, I see this in the CMD window:

                                  UsersCache.fillIn() time = 0  ret==null?: true
                                  java.lang.ArrayIndexOutOfBoundsException: -1
                                          at java.util.ArrayList.elementData(ArrayList.java:422)
                                          at java.util.ArrayList.get(ArrayList.java:435)
                                          at oracle.dbtools.parser.plsql.SyntaxError.checkSyntax(SyntaxError.java:150)
                                          at oracle.dbtools.parser.plsql.SyntaxError.checkSyntax(SyntaxError.java:101)
                                          at oracle.dbtools.parser.plsql.SyntaxError.checkSyntax(SyntaxError.java:94)
                                          at oracle.dbtools.parser.plsql.SyntaxError.checkSQLQuerySyntax(SyntaxError.java:55)
                                          at oracle.dbtools.worksheet.commands.autotrace.AutotraceActionProvider.analyzeSQL(AutotraceActionProvider.java:138)
                                          at oracle.dbtools.worksheet.commands.autotrace.AutotraceActionProvider.checkActionEnabled(AutotraceActionProvider.java:115)
                                          at oracle.dbtools.worksheet.editor.Worksheet$WorksheetController.update(Worksheet.java:722)
                                          at oracle.ide.controller.IdeAction.updateAction(IdeAction.java:787)
                                          at oracle.ide.controller.MenuManager.updateMenuItemAction(MenuManager.java:1257)
                                          at oracle.ide.controller.MenuManager.updateMenuItems(MenuManager.java:1211)
                                          at oracle.ide.controller.MenuManager.access$700(MenuManager.java:93)
                                          at oracle.ide.controller.MenuManager$PrivateMenuListener.menuSelected(MenuManager.java:1346)
                                          at javax.swing.JMenu.fireMenuSelected(JMenu.java:1038)
                                          at javax.swing.JMenu$MenuChangeListener.stateChanged(JMenu.java:1118)
                                          at javax.swing.DefaultButtonModel.fireStateChanged(DefaultButtonModel.java:349)
                                          at javax.swing.DefaultButtonModel.setSelected(DefaultButtonModel.java:232)
                                          at javax.swing.JMenu.setSelected(JMenu.java:305)
                                          at javax.swing.JMenu.menuSelectionChanged(JMenu.java:1187)
                                          at javax.swing.MenuSelectionManager.setSelectedPath(MenuSelectionManager.java:125)
                                          at javax.swing.plaf.basic.BasicMenuUI$Handler.mouseEntered(BasicMenuUI.java:511)
                                          at java.awt.AWTEventMulticaster.mouseEntered(AWTEventMulticaster.java:299)
                                          at java.awt.Component.processMouseEvent(Component.java:6542)
                                          at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
                                          at java.awt.Component.processEvent(Component.java:6298)
                                          at java.awt.Container.processEvent(Container.java:2237)
                                          at java.awt.Component.dispatchEventImpl(Component.java:4889)
                                          at java.awt.Container.dispatchEventImpl(Container.java:2295)
                                          at java.awt.Component.dispatchEvent(Component.java:4711)
                                          at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4889)
                                          at java.awt.LightweightDispatcher.retargetMouseEnterExit(Container.java:4677)
                                          at java.awt.LightweightDispatcher.trackMouseEnterExit(Container.java:4655)
                                          at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4506)
                                          at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4467)
                                  
                                  1 person found this helpful
                                  • 14. Re: Insight completion not working
                                    ANNEC

                                    control+space does not work for me.

                                     

                                    I now changed the number match from 10 to 100.

                                    Now it worked if I just use space after select , but control-space still not work.

                                    I am fine with that.  Thanks

                                    1 2 Previous Next