12 Replies Latest reply on Jun 20, 2018 3:18 AM by Beauty_and_dBest

    EBS 12.0.6 Final upgrade steps

    Beauty_and_dBest

      EBS 12.0.6

      upgrade db 10.2.0.5 to 12.1.0.2

      OL6

       

       

      Hi ALL,

       

      I am in the final steps in upgrading our database.

       

      I need to run autoconfig  on the appstier, but I got error below

       

      [applmgr@oraapps-1 scripts]$ ./adautocfg.sh

       

      Enter the APPS user password:

       

      The log file for this session is located at: /mnt/data/u01/oracle/PPAPROD/inst/apps/PPAPROD_oraapps-1/admin/log/06170033/adconfig.log

       

      AutoConfig is configuring the Applications environment...

       

      AutoConfig will consider the custom templates if present.

              Using CONFIG_HOME location     : /mnt/data/u01/oracle/PPAPROD/inst/apps/PPAPROD_oraapps-1

              Classpath                   : /mnt/data/u01/oracle/PPAPROD/apps/apps_st/comn/java/lib/appsborg2.zip:/mnt/data/u01/oracle/PPAPROD/apps/apps_st/comn/java/classes

       

      Version Conflicts among development maintained and customized templates encountered; aborting AutoConfig run.

       

      The logfile for this session is located at: /mnt/data/u01/oracle/PPAPROD/inst/apps/PPAPROD_oraapps-1/admin/log/06170033/adconfig.log

       

       

      Please help...

       

       

      Kind regards,

      jc

        • 1. Re: EBS 12.0.6 Final upgrade steps
          Jibu-Oracle

          Hi JC,

           

          The customized files are using an older version of the templates and must be updated before autoconfig can be run successfully.

          Autoconfig process is stopping because it has identified a version conflict. The conflict is caused by having customized files and their versions are older than the versions being shipped.

          This conflict needs to be resolved before running autoconfig.

           

          Thanks

          Jibu

          • 2. Re: EBS 12.0.6 Final upgrade steps
            Beauty_and_dBest

            Thanks Jibu and ALL,

             

             

            I check the error log below:

             

            [ VERSION CONFLICTS INFORMATION ]

            Template shipped by oracle is having a version different than the template lying in custom directory.

            Template shipped by Oracle : /mnt/data/u01/oracle/PPAPROD/apps/apps_st/appl/ad/12.0.0/admin/template/APPLSYS_ux.env(version: 120.24.12000000.7)

            Custom template            : /mnt/data/u01/oracle/PPAPROD/apps/apps_st/appl/ad/12.0.0/admin/template/custom/APPLSYS_ux.env(version: 120.24.12000000.6)

            Please resolve the differences between the two templates or refer to Metalink Note 387859.1 for further details.

             

            All driver files processed.

             

            Noted that template shipped by oracle is newer version, while custom template is older?

             

            So what I did is, I backed-up custom template and copy the template shipped from oracle.

             

            Then run autoconfig:

             

            I run now but had error at end:

             

            Attempting upload of Context file and templates to database...COMPLETED

             

            Configuring templates from all of the product tops...

            Configuring AD_TOP........COMPLETED
            Configuring FND_TOP.......COMPLETED
            Configuring ICX_TOP.......COMPLETED
            Configuring IEO_TOP.......COMPLETED
            Configuring BIS_TOP.......COMPLETED
            Configuring AMS_TOP.......COMPLETED
            Configuring CCT_TOP.......COMPLETED
            Configuring WSH_TOP.......COMPLETED
            Configuring CLN_TOP.......COMPLETED
            Configuring OKE_TOP.......COMPLETED
            Configuring OKL_TOP.......COMPLETED
            Configuring OKS_TOP.......COMPLETED
            Configuring CSF_TOP.......COMPLETED
            Configuring IGS_TOP.......COMPLETED
            Configuring IBY_TOP.......COMPLETED
            Configuring JTF_TOP.......COMPLETED
            Configuring MWA_TOP.......COMPLETED
            Configuring CN_TOP........COMPLETED
            Configuring CSI_TOP.......COMPLETED
            Configuring WIP_TOP.......COMPLETED
            Configuring CSE_TOP.......COMPLETED
            Configuring EAM_TOP.......COMPLETED
            Configuring FTE_TOP.......COMPLETED
            Configuring ONT_TOP.......COMPLETED
            Configuring AR_TOP........COMPLETED
            Configuring AHL_TOP.......COMPLETED
            Configuring OZF_TOP.......COMPLETED
            Configuring IES_TOP.......COMPLETED
            Configuring CSD_TOP.......COMPLETED
            Configuring IGC_TOP.......COMPLETED

             

            AutoConfig completed with errors.

            [applmgr@oraapps-1 scripts]$

             

             

            Should I try copying the older template instead?

             

             

            Please help....

             

            Kind regards,

            • 3. Re: EBS 12.0.6 Final upgrade steps
              Beauty_and_dBest

              Hi ALL,

               

              I checked the autoconfig error:

               

              ---------------------------------------------------------------

                                 ADX Database Utility

              ---------------------------------------------------------------

               

              getConnectionUsingAppsJDBCConnector() -->

                  APPS_JDBC_URL=''

                  Trying to get connection using SID based connect descriptor

              getConnection() -->

                  sDbHost    : oradb-1

                  sDbDomain  : prompt.ppa

                  sDbPort    : 1521

                  sDbSid     : PPAPROD

                  sDbUser    : APPS

                  Trying to connect using SID...

              getConnectionUsingSID() -->

                  JDBC URL: jdbc:oracle:thin:@oradb-1.prompt.ppa:1521:PPAPROD

                  Exception occurred: java.sql.SQLException: ORA-28040: No matching authentication protocol

               

                  Trying to connect using SID as ServiceName

              getConnectionUsingServiceName() -->

                  JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=oradb-1.prompt.ppa)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PPAPROD)))

                  Exception occurred: java.sql.SQLException: ORA-28040: No matching authentication protocol

               

                  Trying to connect using SID as ServiceName.DomainName

              getConnectionUsingServiceName() -->

                  JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=oradb-1.prompt.ppa)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PPAPROD.prompt.ppa)))

                  Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:

              ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

              The Connection descriptor used by the client was:

              (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=oradb-1.prompt.ppa)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PPAPROD.prompt.ppa)))

               

                  Connection could not be obtained; returning null

               

              -------------------ADX Database Utility Finished---------------

               

                      Verifying connection to the Database   : Could not be stablished

                      No Restore Profile file created.

               

              Restore Profile utility ran successfully

              ===========================================================================

               

              adcvmlog.xml renamed to /mnt/data/u01/oracle/PPAPROD/inst/apps/PPAPROD_oraapps-1/admin/log/06170339/adcvmlog.xml.06170342

               

              [AutoConfig Error Report]

              The following report lists errors AutoConfig encountered during each

              phase of its execution.  Errors are grouped by directory and phase.

              The report format is:

                    <filename>  <phase>  <return code where appropriate>

               

                [SETUP PHASE]

                AutoConfig could not successfully execute the following scripts:

                  Directory: /mnt/data/u01/oracle/PPAPROD/inst/apps/PPAPROD_oraapps-1/admin/install

                    adgendbc.sh             INSTE8_SETUP       1

               

              AutoConfig is exiting with status 1

               

               

              Please help how to resolve:

              JDBC URL: jdbc:oracle:thin:@oradb-1.prompt.ppa:1521:PPAPROD

              Exception occurred: java.sql.SQLException: ORA-28040: No matching authentication protocol

              Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:

              ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

              The Connection descriptor used by the client was:

              (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=oradb-1.prompt.ppa)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=PPAPROD.prompt.ppa)))

               

               

               

               

              Kind regards,

              • 4. Re: EBS 12.0.6 Final upgrade steps
                Magnanimous

                Please do the following on Application Tier -

                tnsping PPAPROD.prompt.ppa

                 

                And see if you are able to connect or not. If not then you need to fix this issue first.

                 

                Prashant

                • 5. Re: EBS 12.0.6 Final upgrade steps
                  Magnanimous

                  Can you confirm whats the JDK version on the server?

                  • 6. Re: EBS 12.0.6 Final upgrade steps
                    Beauty_and_dBest

                    Hi Prasant,

                     

                    I can tnsping the database server.

                     

                    What command to run to get JDK version?

                     

                     

                     

                    Kind regards,

                    • 7. Re: EBS 12.0.6 Final upgrade steps
                      Magnanimous

                      Please confirm the following -

                      EBS version  and java version -

                      JAVA_TOP/bin

                      java -version

                      • 8. Re: EBS 12.0.6 Final upgrade steps
                        Beauty_and_dBest

                        Thanks Prasant, I check that...brb (right now i can not access the upgrade servers).

                        • 9. Re: EBS 12.0.6 Final upgrade steps
                          Magnanimous

                          Ok, please set this parameter

                          SQLNET.ALLOWED_LOGON_VERSION_SERVER = 8

                          And check if issue is resolved.

                           

                          Prashant Umap

                          • 10. Re: EBS 12.0.6 Final upgrade steps
                            Beauty_and_dBest

                            Thanks Prasant,

                             

                            Do I add that to listener.ora? or tnsnames.ora?

                            • 11. Re: EBS 12.0.6 Final upgrade steps
                              Magnanimous

                              sqlnet.ora at database side.

                              And whats the database version. Also update -

                              SQLNET.ALLOWED_LOGON_VERSION_SERVER=8

                              • 12. Re: EBS 12.0.6 Final upgrade steps
                                Beauty_and_dBest

                                Thanks Prasant

                                 

                                It resolved the issue