10117518_CUP8  pre-uprade error

Beauty_and_dBest

    Upgrade EBS 12.1.3 to 12.2.0

     

    Hi ALL,

     

    As part of the upgrade process, I am now following this docs  >

    Oracle E-Business Suite Release Notes, Release 12.2 (Doc ID 1320300.1)

    3.1 Apply Consolidated Upgrade Patch and Run 12.2.0 Upgrade (required)

     

    I already merged the patch, and apply it using adpatch preinstall=y

     

    But I got error below

     

    Enter the directory where your Oracle E-Business Suite patch has been unloaded

     

    The default directory is [/u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8] :

     

    Please enter the name of your AutoPatch driver file : u_10117518_cup8.drv

     

    Getting Oracle E-Business Suite Release...

     

    Current installed release is  12.0.0

     

    Reading patch driver file...

     

      Parsing and loading patch driver file...

        Processing line   10000.

          14320 lines processed.

     

      Not checking patch integrity as integrity checking flag is turned off.

     

    Successfully read patch driver file.

     

    Determining target release...

     

    Current target    release is  12.0.0

     

    Warning:

     

    The description for the entity 'ad' in the patch driver

    does not match with the current description.

     

    The current description is      :'Applications DBA'

    The description in the patch is :'Oracle Applications DBA'

     

    The current description will not be changed

    as adpatch is running in preinstall mode.

     

     

    AutoPatch error:

    A codeline or codelevel introducing patch cannot be applied in pre-install mode.

     

    AutoPatch error:

    --------

    A fatal error related to codelines or codelevels has occurred.

     

    See messages above for details.

    --------

     

    You should check the file

    /u04/appprod/PROD/fs1/EBSapps/appl/admin/PROD/log/adpatch.log

     

    for errors.

     

    [appprod@test01 10117518_CUP8]$

     

    Why is it saying my instance is 12.0.0? When I already run rapidwiz pre-upgrade 12.2.0?

     

     

    Please help how to apply this merge patch

     

     

    Kind regards,

    jc

      • 1. Re: 10117518_CUP8  pre-uprade error
        Shaik

        Hi JC

         

        there is a pre-req patch 26321002:R12.AD.C for  Patch 10117518  so merge the three patches and try to apply in preinstall mode.

        Patches to merge: 10117518  24690501  26321002

         

         

        Regards

        Shaik

        • 2. Re: 10117518_CUP8  pre-uprade error
          Shaik

          Hi JC

           

          even you have to use full merge using option -admode as below

           

          admrgpch -s /source dir -d /destination/10117518_CUP8 -merge_name 10117518_cup8 -admode

           

          Regards

          Shaik

          • 3. Re: 10117518_CUP8  pre-uprade error
            Beauty_and_dBest

            Thanks Shaik,

             

            That is what I exactly did, following the README.txt in 10117518.

             

            2. Instructions to merge and apply R12.AD.C,AD CUP8 and 26321002:R12.AD.C [required]

            When directed to apply AD 12.2.0 (R12.AD.C) in Chapter 3, Upgrading to Release 12.2 within "Oracle E-Business Suite Upgrade Guide 12.0 and

            12.1 to 12.2" and "Oracle E-Business Suite Upgrade Guide 11i to 12.2", perform the following steps instead:

             

            1.1) Merge R12.AD.C (patch#10117518) with AD CUP8 patch (patch#24690501:R12.AD.C) and 26321002:R12.AD.C

                  Note: This merge should be a full merge using -admode. Do not use -preinstall or -driveronly mode.

                  Example: a. Download and unzip R12.AD.C (patch#10117518) ,12.2.0 AD CUP8 patch#24690501:R12.AD.C and 26321002:R12.AD.C under <PATCH_TOP>/AD_source

                           b. mkdir -p <PATCH_TOP>/10117518_CUP8

                           c. admrgpch -s <PATCH_TOP>/AD_source -d <PATCH_TOP>/10117518_CUP8 -merge_name 10117518_cup8 -admode

             

            And then do below as >>  adpatch preinstall=y

            1.2) Apply the merged patch driver in its entirety following the Pre-Install and Post-Install Tasks of R12.AD.C (patch#10117518) .

             

            I checked the merge log, and I see >>> WARNING: Ignoring the current driver file /u01/PATCH/UPGRADE_PATCH_APP/24690520/u24690520.drv, since it is non-AD's driver file

             

            ************* Start of AD Merge Patch session *************

            AD Merge Patch version: 12.0.0

            AD Merge Patch started at: Wed Jul 04 2018 15:58:22

             

            Options : "-s /u01/PATCH/UPGRADE_PATCH_APP -d /u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8 -merge_name 10117518_cup8 -admode "

              NLS_LANG Character Set is: UTF8

             

            Executing the merge of the patch drivers

             

            STRT_TASK: [Looping through patch driver files] [Wed Jul 04 2018 15:58:22]

            -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/26321002

            -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/26321002/u26321002.drv

            Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/26321002/u26321002.drv ...

            Patch Character Set is: us7ascii

            -- Merging patch driver : /u01/PATCH/UPGRADE_PATCH_APP/26321002/u26321002.drv

            -- Done processing file: /u01/PATCH/UPGRADE_PATCH_APP/26321002/u26321002.drv

            -- Done merging patch: /u01/PATCH/UPGRADE_PATCH_APP/26321002

            -- Done processing patch: /u01/PATCH/UPGRADE_PATCH_APP/26321002

             

            No driver files exists in /u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8.

            -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/24690520

            -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/24690520/u24690520.drv

            Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/24690520/u24690520.drv ...

             

            WARNING: Ignoring the current driver file /u01/PATCH/UPGRADE_PATCH_APP/24690520/u24690520.drv, since it is non-AD's driver file

             

            -- Done merging patch: /u01/PATCH/UPGRADE_PATCH_APP/24690520

            -- Done processing patch: /u01/PATCH/UPGRADE_PATCH_APP/24690520

             

            -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/10117518

            -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/10117518/u10117518.drv

            Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/10117518/u10117518.drv ...

            Patch Character Set is: us7ascii

            -- Merging patch driver : /u01/PATCH/UPGRADE_PATCH_APP/10117518/u10117518.drv

            .

            .

            .

            Converting character set for file

              /u01/PATCH/UPGRADE_PATCH_APP/26321002/f26321002.ldt

            from 'US7ASCII'to 'UTF8'... Done.

            Source file:

              /u01/PATCH/UPGRADE_PATCH_APP/26321002/f26321002.ldt

            Destination file:

              /u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8/f26321002.ldt

             

            Adncnv completed successfully.

             

            Please check the adncnv logfile at admrgpch.log.

             

            STOP_TASK: [Character-set converting files] [Wed Jul 04 2018 15:58:23]

             

              3 unified drivers merged.

             

            Patch merge completed successfully

             

            Please check the log file at ./admrgpch.log.

             

             

             

             

            Please help....

             

             

            Kind regards,

            • 4. Re: 10117518_CUP8  pre-uprade error
              Beauty_and_dBest

              Hi Shaik,

               

              Sorry, I noticed I had another patch included in the merge folder which is 24690520.

               

              I run the merge patch again with output log below:

              ************* Start of AD Merge Patch session *************

              AD Merge Patch version: 12.0.0

              AD Merge Patch started at: Wed Jul 04 2018 20:34:57

               

              Options : "-s /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE -d /u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8 -merge_name 10117518_cup8 -admode "

                NLS_LANG Character Set is: UTF8

               

              Executing the merge of the patch drivers

               

              STRT_TASK: [Looping through patch driver files] [Wed Jul 04 2018 20:34:57]

              -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002

              -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002/u26321002.drv

              Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002/u26321002.drv ...

              Patch Character Set is: us7ascii

              -- Merging patch driver : /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002/u26321002.drv

              -- Done processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002/u26321002.drv

              -- Done merging patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002

              -- Done processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/26321002

               

              -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518

              -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518/u10117518.drv

              Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518/u10117518.drv ...

              Patch Character Set is: us7ascii

              -- Merging patch driver : /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518/u10117518.drv

              -- Done processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518/u10117518.drv

              -- Done merging patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518

              -- Done processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/10117518

               

              -- Processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501

              -- Processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501/u24690501.drv

              Reading driver file /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501/u24690501.drv ...

              Patch Character Set is: us7ascii

              -- Merging patch driver : /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501/u24690501.drv

              -- Done processing file: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501/u24690501.drv

              -- Done merging patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501

              -- Done processing patch: /u01/PATCH/UPGRADE_PATCH_APP/AD_SOURCE/24690501

               

               

               

               

              But when I apply > adpatch preinstall=y, I got error below

               

               

              Saving product information.

              Not checking the system maintenance mode.

               

              Not uploading patch history information from filesystem

               

              Enter the directory where your Oracle E-Business Suite patch has been unloaded

               

              The default directory is [/u01/PATCH/UPGRADE_PATCH_APP/10117518_CUP8] :

               

              Please enter the name of your AutoPatch driver file : u_10117518_cup8.drv

               

              Getting Oracle E-Business Suite Release...

               

              Current installed release is  12.0.0

               

              Reading patch driver file...

               

                Parsing and loading patch driver file...

                  Processing line   10000.

                    14300 lines processed.

               

                Not checking patch integrity as integrity checking flag is turned off.

               

              Successfully read patch driver file.

               

              Determining target release...

               

              Current target    release is  12.0.0

               

              Warning:

               

              The description for the entity 'ad' in the patch driver

              does not match with the current description.

               

              The current description is      :'Applications DBA'

              The description in the patch is :'Oracle Applications DBA'

               

              The current description will not be changed

              as adpatch is running in preinstall mode.

               

              AutoPatch error:

              A codeline or codelevel introducing patch cannot be applied in pre-install mode.

               

              AutoPatch error:

              --------

              A fatal error related to codelines or codelevels has occurred.

               

              See messages above for details.

              --------

               

              You should check the file

              /u04/appprod/PROD/fs1/EBSapps/appl/admin/PROD/log/adpatch.log

               

              for errors.

               

              [appprod@test01 10117518_CUP8]$

               

               

               

              Please help...

               

              Kind regards,

              • 5. Re: 10117518_CUP8  pre-uprade error
                Shaik

                Hi JC

                 

                please check the belwo community thread where same issue mentioned

                https://support.oracle.com/epmos/faces/CommunityDisplay?resultUrl=https%3A%2F%2Fcommunity.oracle.com%2Fthread%2F3952194&…

                 

                 

                Regards

                Shaik

                • 6. Re: 10117518_CUP8  pre-uprade error
                  Shaik

                  Hi JC

                   

                  apply the patch with adpatch  don't go with preinstall for this merge patch,

                  in next step we can see Consolidated Upgrade Patch (CUP) for Release 12.2.0 (Patch 24690520:12.2.0) in pre-installation mode on the Run Edition File System

                   

                   

                  Regards

                  Shaik

                  • 7. Re: 10117518_CUP8  pre-uprade error
                    Beauty_and_dBest

                    Thanks Shaik,

                     

                    The link said to apply it as normal patch?

                    But why does others people able to apply it preinstall=y? Oracle APPS DBA pieces: Oracle E-Business Suite upgrade from 12.1.1 to 12.2.7

                     

                    Anyways, I will try the normal option...brb

                    • 8. Re: 10117518_CUP8  pre-uprade error
                      Shaik

                      Hi JC

                       

                      something wrong in that doc, i have doublechecked my documents me too applied without preinstall option

                       

                      so apply the patch with normal options

                       

                      Regards

                      Shaik

                      • 9. Re: 10117518_CUP8  pre-uprade error
                        Beauty_and_dBest

                        Hi Shaik,

                         

                        Re: the next step patch 24690520, I have not yet run this. But I understand the docs said to run it as preinstall=y  right?

                         

                        Kind regards,

                        • 10. Re: 10117518_CUP8  pre-uprade error
                          Beauty_and_dBest

                          Hi Shaik,

                           

                          The merge patch is running now, but it is slow becuase it is updating snapshot table every set of records

                          How do I disable it?

                           

                          No of records processed =428351

                             Updating Snapshot Tables...Start time:Wed Jul 04 2018 21:10:38

                                Done Updating Snapshot Tables for the above rows...End Time:Wed Jul 04 2018 21:10:40

                           

                          No of records processed =433351

                             Updating Snapshot Tables...Start time:Wed Jul 04 2018 21:10:41

                                Done Updating Snapshot Tables for the above rows...End Time:Wed Jul 04 2018 21:10:41

                           

                          No of records processed =438351

                             Updating Snapshot Tables...Start time:Wed Jul 04 2018 21:10:45

                                Done Updating Snapshot Tables for the above rows...End Time:Wed Jul 04 2018 21:10:46

                           

                          No of records processed =443351

                             Updating Snapshot Tables...Start time:Wed Jul 04 2018 21:10:48

                                Done Updating Snapshot Tables for the above rows...End Time:Wed Jul 04 2018 21:10:48

                          • 11. Re: 10117518_CUP8  pre-uprade error
                            Beauty_and_dBest

                            Hi Shaik,

                             

                            I forgot to run the apply patch in  VNC server client so that I can close the monitor or shutdown the laptop

                             

                            Right now It was running on putty and I can not logoff to sleep   30,000 jobs still waiting to run.

                             

                            How do I transfer it to VNC client? Can I close putty and reopen in on VNC client window?

                             

                             

                             

                            Please help....

                             

                             

                            Kind regards,

                            • 12. Re: 10117518_CUP8  pre-uprade error
                              Shaik

                              Hi JC

                               

                              you cant transfer to VNC.

                               

                              Regards

                              Shaik

                              • 13. Re: 10117518_CUP8  pre-uprade error
                                Beauty_and_dBest

                                Thanks Shaik,

                                 

                                The putty session already timed out due to no-activity for long time. So the running patch is now disconnected.

                                How do I transfer it to VNC or recover it from there?

                                 

                                 

                                Kind regards,

                                • 14. Re: 10117518_CUP8  pre-uprade error
                                  Shaik

                                  Hi JC

                                   

                                  You have to restart the adpatch session in vnc

                                   

                                  Regards

                                  Shaik

                                  1 2 上一个 下一个