5 Replies Latest reply on Jul 12, 2018 1:35 PM by thatJeffSmith-Oracle

    Unable to run SQL Developer: Closes after startup

    1429c2a7-fd15-43cb-aa0b-e684a46b8450

      So, I "just" installed SQL developer in my Windows 10 and I haven't managed to make it work: After showing the UI for a few seconds it closes.

       

       

      Downloaded from Windows 64-bit with JDK 9 included from Oracle SQL Developer Downloads since my current Java installation is Java 10.0.1.

       

       

      Solutions already tried:

       

      - Update Graphics Cards Driver

      - Delete SQL Developer appdata folder

      - Unziping sqldeveloper in different place than Program Files (Directly in C:)
      - Running as admin
      - Running with compatibility modes for windows XP, 7 and 8

       

       

      Also tried downloading the version without JDK 9 and linking to my Java 10 instalation, that worked even worse since it got stuck after having reflection issues while loading.

       

      Current CMD log:

       

      C:\sqldeveloper\sqldeveloper\bin>sqldeveloper.exe

      Exception in thread "JavaFX Application Thread" java.lang.NoSuchMethodError: fwkRunBeforeUnloadConfirmPanel

              at javafx.web/com.sun.webkit.WebPage.twkInit(Native Method)

              at javafx.web/com.sun.webkit.WebPage.<init>(Unknown Source)

              at javafx.web/javafx.scene.web.WebEngine.<init>(Unknown Source)

              at javafx.web/javafx.scene.web.WebEngine.<init>(Unknown Source)

              at javafx.web/javafx.scene.web.WebView.<init>(Unknown Source)

              at oracle.dbtools.raptor.startpage.StartPageViewer$Browser.<init>(StartPageViewer.java:588)

              at oracle.dbtools.raptor.startpage.StartPageViewer.initFX(StartPageViewer.java:219)

              at oracle.dbtools.raptor.startpage.StartPageViewer.lambda$createGUIComponent$0(StartPageViewer.java:187)

              at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$9(Unknown Source)

              at java.base/java.security.AccessController.doPrivileged(Native Method)

              at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$10(Unknown Source)

              at javafx.graphics/com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)

              at javafx.graphics/com.sun.glass.ui.win.WinApplication._runLoop(Native Method)

              at javafx.graphics/com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(Unknown Source)

              at java.base/java.lang.Thread.run(Unknown Source)

      #

      # A fatal error has been detected by the Java Runtime Environment:

      #

      #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006158bbaa, pid=33076, tid=32624

      #

      # JRE version: Java(TM) SE Runtime Environment (9.0+11) (build 9.0.4+11)

      # Java VM: Java HotSpot(TM) 64-Bit Server VM (9.0.4+11, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)

      # Problematic frame:

      # V  [jvm.dll+0x37bbaa]

      #

      # No core dump will be written. Minidumps are not enabled by default on client versions of Windows

      #

      # An error report file with more information is saved as:

      # C:\sqldeveloper\sqldeveloper\bin\hs_err_pid33076.log

      #

      # If you would like to submit a bug report, please visit:

      #   http://bugreport.java.com/bugreport/crash.jsp

      #

       

       

      [error occurred during error reporting (), id 0xc0000005]

       

      Any suggestions? Thanks in advance!