1 Reply Latest reply on Aug 22, 2018 9:37 PM by thatJeffSmith-Oracle

    Set optimization level to 1 raise PLS-06015

    3666141

      Hi,

       

      On development environment, in order to avoid adding debug information manually, I used to set optimization level to 1 in "Database/PL/SQL compiler" preferences.

      I also set ALL to ENABLE.

       

      On compilation, I got the following warning  "Error: PLS-06015: parameter PLSQL_DEBUG is deprecated; use PLSQL_OPTIMIZE_LEVEL = 1"

      There is an easy workaround (not to set ALL to DISABLE), but it would be nice to get it fixed, in order to focus on user-code relative messages.

       

      I got this on SQL Developper 18.1, but the issue has already been tracked a couple of years ago by @user13256715 in  the following thread

      PLW-06015 when compilling for debug

       

      Thanks !