11 Replies Latest reply on Oct 23, 2018 11:00 AM by Beauty_and_dBest

    How to apply patch 12.2.8 to existing EBS R12.2.7 instance?

    Beauty_and_dBest

      EBS 12.2.7  to 12.2.8

       

       

      Hi ALL,

       

      I want to apply  patch 12.2.8  to our existing EBS R12.2.7 instance.

      I am now following the Document > Oracle E-Business Suite Release 12.2.8 Readme (Doc ID 2393248.1)

       

      Why is section 4 only ask to check database patches? Is this not applicable to apps-tier  or not needed?

       

      First step on the list is:

       

      1. Run ETCC on the Database Tier.

          I downloaded the latest ETCC  Patch 17537119)  and run

       

      $ ./checkDBpatch.sh

       

      +===============================================================+

      |    Copyright (c) 2005, 2018 Oracle and/or its affiliates.     |

      |                     All rights reserved.                      |

      |             Oracle E-Business Suite Release 12.2              |

      |          Database EBS Technology Codelevel Checker            |

      +===============================================================+

       

      Using context file from currently set database environment:

      /u02/orauat/UAT/12.1.0/appsutil/UAT_trnsrvr.xml

       

       

      Starting Database EBS Technology Codelevel Checker, Version 120.65

      Thu Oct 11 13:50:15 +08 2018

      Log file for this session : /u01/PATCH/ETCC/log/checkDBpatch_28162.log

       

      Identifying database release.

      Database release set to 12.1.0.2.

       

      Connecting to database.

      Database connection successful.

       

      Database UAT is in READ WRITE mode.

       

      Identifying APPS and APPLSYS schema names.

      - APPS schema : APPS

      - APPLSYS schema : APPLSYS

       

      Checking for DB-ETCC results table.

      Table to store DB-ETCC results already exists in the database.

       

      Checking if InMemory option is enabled.

      InMemory option is not enabled in the database.

       

      Bugfix file ./db/onprem/txk_R1220_DB_base_bugs.xml : 120.0.12020000.43

      This file will be used for identifying missing bugfixes.

       

      Mapping file ./db/onprem/txk_R1220_DB_mappings.xml : 120.0.12020000.18

      This file will be used for mapping bugfixes to patches.

       

       

      [WARNING] DB-ETCC: Bugfix XML file (./db/onprem/txk_R1220_DB_base_bugs.xml) is more than 30 days old.

      Check if a newer version is available in patch 17537119.

       

      Checking Bugfix XML file for 12.1.0.2_BP

       

      Obtained list of bugfixes to be applied and the list to be rolled back.

      Now checking Database ORACLE_HOME.

       

      The opatch utility is version 12.2.0.1.8.

      DB-ETCC is compatible with this opatch version.

       

      Found patch records in the inventory.

       

      Checking Mapping XML file for 12.1.0.2.180116ProactiveBP

       

      Patch mapping not available.

      Patch mapping data is not available for 12.1.0.2 ProactiveBP

      Some required one-off bugfixes are missing from the Database ORACLE_HOME.

      The missing bugfixes are:

      20801452

      26336977

      26654363

      26742604

      27547374

      27997875

       

      ** Refer to MOS Doc ID "1594274.1:Oracle E-Business Suite Release 12.2: Consolidated List of Patches and Technology Bug Fixes" to find the corresponding patch that delivers the bug fix. If an overlay patch is needed for any particular patch listed, the footnote for that patch also applies to the overlay patch. **

       

      Apply the missing bugfixes and then rerun the script.

       

      Stored Technology Codelevel Checker results in the database UAT successfully.

       

      Finished checking fixes for Oracle Database: Thu Oct 11 13:50:34 +08 2018

       

      Log file for this session: /u01/PATCH/ETCC/log/checkDBpatch_28162.log

       

      ===============================================================================

      [orauat@trnsrvr ETCC]$

       

      Why does it always say >

      [WARNING] DB-ETCC: Bugfix XML file (./db/onprem/txk_R1220_DB_base_bugs.xml) is more than 30 days old.

      Check if a newer version is available in patch 17537119.

       

      Even if I just downloaded the etcc patch right now? What inventory check does it read?

       

       

      I tried to download the first patch above, but support site says it already obsolete?

      Why ETCC is still recommending obsolete patch? What do wedo  to clear up the ETCC?

       

      For the 2nd patch, is it okay to download the ProactiveBP version? What is this version for?

      For patch 27547374 does not exist but only extension? Which one do I download?

       

       

       

      Please shed lights....

       

       

       

      Kind regards,

      jc

        • 1. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
          Beauty_and_dBest

          Hi ALL,

           

          $ ./checkMTpatch.sh

           

          +===============================================================+

          |    Copyright (c) 2005, 2016 Oracle and/or its affiliates.     |

          |                     All rights reserved.                      |

          |             Oracle E-Business Suite Release 12.2              |

          |        Applicatione Tier Technology Codelevel Checker         |

          +===============================================================+

           

          Using context file from currently set applications environment:

          /u02/appuat/UAT/fs1/inst/apps/UAT_trnsrvr/appl/admin/UAT_trnsrvr.xml

           

          Starting Application Tier Technology Codelevel Checker

          Version: 120.0.12020000.34.

          Thu Oct 11 13:57:44 +08 2018

          Log file for this session: /u01/PATCH/ETCC/log/checkMTpatch_29744.log

           

          Bugfix XML file version: 120.0.12020000.36

          This file will be used for identifying missing bugfixes.

           

          Mapping XML file version: 120.0.12020000.21

          This file will be used for mapping bugfixes to patches.

           

          Checking for prerequisite bugfixes in File Edition: run

           

          Enter the password for the APPS user:

          Connecting to database.

          Database connection successful.

          The installed AD.C.10 codelevel supports storing the results in the database.

           

          Checking for ETCC results table.

          Table to store results already exists in database.

           

          ===============================================================================

          Oracle Forms and Reports

          ===============================================================================

          Now examining product Oracle Forms and Reports.

           

          Oracle Home = /u02/appuat/UAT/fs1/EBSapps/10.1.2.

          Product version = 10.1.2.3.0.

          Checking required bugfixes for Oracle Forms and Reports 10.1.2.3.0.

          All required bugfixes are present for Oracle Forms and Reports.

          These results have been stored in the database.

           

          Checking required bugfixes for RSF within Forms 10.1.0.5.0.

          All required bugfixes are present for RSF within Forms.

          These results have been stored in the database.

           

          ===============================================================================

          Oracle Fusion Middleware (FMW) - Web Tier

          ===============================================================================

          Now examining product Oracle Fusion Middleware (FMW) - Web Tier.

           

          Oracle Home = /u02/appuat/UAT/fs1/FMW_Home/webtier.

          Product Version = 11.1.1.9.0

          Checking required bugfixes for FMW - Web Tier 11.1.1.9.0.

          All required bugfixes are present for FMW - Web Tier.

          These results have been stored in the database.

           

          Checking required bugfixes for RSF within FMW Web tier 11.1.0.7.0.

            Missing Bugfix: 7572595  ->  Patch 7572595

          The above list shows missing bugfixes for RSF within FMW Web tier.

          These results have been stored in the database.

           

          ===============================================================================

          Oracle Fusion Middleware (FMW) - oracle_common

          ===============================================================================

          Now examining product Oracle Fusion Middleware (FMW) - oracle_common.

           

          Oracle Home = /u02/appuat/UAT/fs1/FMW_Home/oracle_common.

          Product Version = 11.1.1.9.0

          Checking required bugfixes for FMW - oracle common 11.1.1.9.0.

          All required bugfixes are present for FMW - oracle common.

          These results have been stored in the database.

           

          ===============================================================================

          Oracle WebLogic Server (WLS)

          ===============================================================================

          Now examining product Oracle WebLogic Server (WLS).

           

          Oracle Home = /u02/appuat/UAT/fs1/FMW_Home/wlserver_10.3.

          Product Version = 10.3.6.0.171017

           

          Note that for Oracle WebLogic Server, patches rather than bugfixes are verified.

           

          Checking required patches for Oracle WebLogic Server (WLS) 10.3.6.0.171017.

          All required patches are present for Oracle WebLogic Server (WLS).

          These results have been stored in the database.

           

          ===============================================================================

           

          Generating Patch Recommendation Summary.

           

          ===============================================================================

          PATCH RECOMMENDATION SUMMARY

          ===============================================================================

          One or more products have bugfixes missing.

          The default patch recommendations to install these missing bugfixes are:

           

          -------------------------------------------------------------------------------

          RSF within FMW Web tier 11.1.0.7.0

          -------------------------------------------------------------------------------

            Patch 7572595

              - Filename: p7572595_111070_Linux-x86-64.zip

           

           

          Apply the required patches and rerun this script.

           

          +-----------------------------------------------------------------------------+

          A consolidated zip file with the required application tier patches is

          available on My Oracle Support via:

           

            Patch 28128413

              - EBS RELEASE 12.2 CONSOLIDATED FMW FIXES FOR JUL 2018

           

          +-----------------------------------------------------------------------------+

           

          See Doc ID 1594274.1 for any special instructions regarding these patches.

          Footnotes in Doc ID 1594274.1 also apply to corresponding overlay patches.

           

          Finished checking prerequisite patches for File Edition: run.

          Thu Oct 11 13:58:22 +08 2018

           

          Log file for this session: /u01/PATCH/ETCC/log/checkMTpatch_29744.log

           

          ===============================================================================

          [appuat@trnsrvr ETCC]$

           

           

          Do I need to apply above? or optional only?

           

           

          Kind regards,

          • 2. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
            mdtaylor

            Hi jc,

             

            please post the results of opatch lsinventory from your database home So we can see where you are starting from.

             

            Regards,

            Michael

            • 3. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
              Beauty_and_dBest

              Thanks Michael,

               

              The opatch lsinventory is to big with 455 lines

              Is it possible to attached it here?

              I tried to find the attachment tool but I can not find it in my screen. Maybe my id is not granted with it?

               

              Kind regards,

              jc

              • 4. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                mdtaylor

                Hi jc,

                 

                For the 12c DB home, I recommend starting with the Database overlay patching document:

                 

                Database Patch Set Update Overlay Patches Required for Use with PSUs and Oracle E-Business Suite (Doc ID 1147107.1)

                 

                You have the January 2018 PSU applied on that instance.  Download and apply the patches from column 3 in the overlay document for 12.1.0.2.180116.

                 

                Screen Shot 2018-10-12 at 8.08.36 AM.png

                Once you have applied all 9 of those patches for the exact versions listed, rerun the ETCC checker.

                 

                For the missing RSF 11.1.1.7 patch, yes, you need to apply that to the listed Oracle Home and rerun the ETCC checker for the middle tier.

                 

                Regards,

                Michael

                • 5. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                  Beauty_and_dBest

                  Thanks Michael,

                   

                  I do not understand this "overlaying" thing. I will just follow what to advise to do

                  I will apply first all the 9 patches in column 3  plus RSF 11.1.1.7  patch....

                  Will be back for next steps ones completed

                   

                  Kind regards,

                  • 6. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                    Beauty_and_dBest

                    Hi Michael,

                     

                    I am downloading the 9 patches, but I can not find 27528373.

                    Do I need to skip this one?

                     

                     

                    Kind regards,

                    • 7. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                      mdtaylor

                      Hi jc,

                       

                      Please create an SR referencing the overlay note and ask why the patch 27528373 in the document is not available on Oracle Support.

                       

                      Regards,

                      Michael

                      • 8. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                        Beauty_and_dBest

                        Thanks Michael,

                         

                        Maybe it is not so "important"  a patch after all or it can be applied later when upgrade to 12.2.8 is completed?

                         

                         

                        Kind regards,

                        • 9. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                          Pravin Takpire

                          I would also suggest to Raise SR for patch 27528373  and meanwhile keep on doing upgrade.

                           

                          regards

                          Pravin

                          • 10. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                            Beauty_and_dBest

                            Hi Michael & Pravin,

                             

                            I raised an SR and the support just replied:

                             

                            The patch 27528373 it's not available any more so you can't download it.

                             

                             

                            What do I gonna tell him?

                             

                             

                            Kind regards,

                            • 11. Re: How to apply patch 12.2.8 to existing EBS R12.2.7 instance?
                              Beauty_and_dBest

                              Hi Michael, Pravin, and ALL,

                               

                              The SR support advised to apply the overlay patches below,  instead of > the January 2018 PSU applied on our instance. 

                              Is this  okay fine?

                               

                               

                              Please help...

                               

                               

                              Kind regards,