1 2 Previous Next 16 Replies Latest reply on Mar 13, 2019 8:10 PM by L. Fernigrini

    Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1

    6af75829-11ed-41a1-ba95-f63174c83315

      Hello I'am a Student and need Oracle to study.

       

      Now I tried to Install the new XE on an Ubuntu Server.

       

      To make sure all Packages are installied I followed the Manual Setep from hier:

      https://oracle-base.com/articles/18c/oracle-db-18c-installation-on-oracle-linux-6-and-7

       

      And the tried to Install XE with the command:

      alien -i oracle-database-xe-18c-1.0-1.x86_64.rpm --scripts

       

      I also tried to first install the prepare.rpm

       

      but every Time the installation isn't succesfull becase of the Error:

      /opt/oracle/product/18c/dbhomeXE/oui/bin/runInstaller.sh: No such file or directory

       

      Has anyone a sulution for my Problem?

        • 1. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
          Haniel Burton

          Look through this article and see if it helps any, you might be missing some scripts or environment variables in Ubuntu that are present in Red Hat based systems:

           

          https://askubuntu.com/questions/566734/how-to-install-oracle-11gr2-on-ubuntu-14-04

           

          Instructions are for 11gR2, but they may still apply.

           

          Also, here's a couple of guides for 12c, which should be even closer to 18c.

           

          https://tutorialforlinux.com/2018/05/09/how-to-install-oracle-12c-r2-database-on-ubuntu-18-04-bionic-64bit-easy-guide/

           

          https://askubuntu.com/questions/1033264/oracle-12-c-db-installation-on-ubuntu-18-04-lts

           

          Any chance you can try to install on CentOS 7 instead?

           

          Install was really smooth from me. I wouldn't know how to try to install on a Debian based OS like Ubuntu and you may not be able to get as much help yet since this was recently released.

          • 2. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
            Billy~Verreynne

            I ran alien on oracle-database-xe-18c-1.0-1.x86_64.rpm, installed the resulting Debian package, fixed ownership of /opt/oracle, and used DBCA to create a CDB with a PDB.

             

            Only issue with the database create is the patching process - have my guesses as to what is wrong, but need to do a RPM install still on Oracle Linux as a base test.

             

            Anyway, XE 18c database and Listener are running without obvious issues on my Ubuntu desktop.

            • 3. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
              Billy~Verreynne

              Update: The deb package on Ubuntu for some reason did not create the Oracle Inventory location file, and associated directory with XML files - which caused non-fatal errors DBCA errors while creating the database.

               

              Unsure at this stage whether I'm bothered enough to try and fix it on my Ubuntu desktop...

              • 4. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                Yves Moriceau-Oracle

                Hi,

                I run the install on a Kali Linux (Debian distri) and it works for me but I need to adapt few scripts..

                First

                Convert & extract the rpm file

                root@kali:~/Downloads# fakeroot alien –cv oracle-database-xe-18c-1.0-1.X86_64.rpm

                (I use fakeroot to avoid any issue - you can get it via  root@kali:~#  sudo apt-get install alien fakeroot)

                Then check your kernel parameters in the installation guide

                root@kali:~/Downloads#  /sbin/sysctl -a | grep sem

                root@kali:~/Downloads#  /sbin/sysctl -a | grep shm

                root@kali:~/Downloads#  /sbin/sysctl -a | grep rmem

                root@kali:~/Downloads#  /sbin/sysctl -a | grep wmem

                root@kali:~/Downloads#  /sbin/sysctl -a | grep file

                root@kali:~/Downloads#  /sbin/sysctl -a | grep net.ipv4.ip_local_port_range

                If the values are not correct simply update /etc/sysctl.conf file by adding e.g.

                ###################################################################

                # Update for Oracle installation

                ###################################################################

                net.ipv4.ip_local_port_range = 9000 65500

                fs.file-max = 6815744

                net.core.rmem_default = 262144

                net.core.rmem_max = 4194304

                net.core.wmem_default = 262144

                net.core.wmem_max = 1048576

                kernel.panic_on_oops = 1

                fs.aio-max-nr = 1048576

                At that stage don't forget to reboot your system if you had to make some Kernel modifications

                 

                You can then the run the script

                root@kali:~/Downloads# dpkg --install ./oracle-database-xe-18c_1.0-2_amd64.deb

                 

                Once it's finished you should get the message

                Executing post-install steps...

                You must run '/etc/init.d/oracle-xe-18c configure' as the root user to configure the database.

                There you may have an issue with dbca (database configuration assistant).

                You may get a kind of memory error. Forget it and opt for a manual run (be careful about your passwords and check if your file are also in /opt/oracle)

                Also make sure that you environment variable PATH is well positioned to recognize dbca command and ORACLE_BASE might need to be positioned as well

                root@kali:~/Downloads# dbca -createDatabase -silent -gdbName ora18c -templateName XE_Database.dbc -sysPassword YourPWD1 -systemPassword YourPWD1 -dbsnmpPassword YourPWD1 -datafileDestination /opt/oracle/oradata -storageType FS -memoryPercentage 20 -emConfiguration NONE -sampleSchema false -J-Doracle.assistants.dbca.validate.ConfigurationParams=false

                 

                Hope it will help you

                Rgds,

                Yves

                • 5. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                  34fa050e-7873-4c97-8487-c8861030a5cf

                  Great!!!  Thank You Very Much

                  It's Work For Me  UBUNTU SERVER 18.04

                  • 6. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                    venky513

                    HI ,

                     

                    I did everything the same way but installation failed at the last step at dbca config :

                    [FATAL] Error while cataloging RMAN Backups oracle 18

                     

                    SEVERE: [FATAL] Error while cataloging RMAN Backups

                     

                     

                    Any suggestions please. stuck from 3 days

                    trying to install  oracle 18c xe  on 18.4 ubuntu

                    • 7. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                      gerhard2001

                      Hi to all!

                       

                      I did installations of former versions of OracleXE (10g and 11g) on Ubuntu and Debian in the following way.

                      I hope it works with XE 18c too.

                       

                       

                      Installation von OracleXE 11g 64bit on Debian 7 (64bit):

                       

                      Debian Linux and Ubuntu Linux are not supported by Oracle.

                      But you can install Oracle on Debian (Ubuntu) by doing the following steps:

                       

                      -----------------------------------------------------------
                      First of all:

                       

                      Do the following to avoid getting MEMORY TARGET error ( ORA-00845: MEMORY_TARGET not supported on this system ) :

                      It's just a matter of adding an entry into /etc/fstab for the shared memory temporary file system mounted at /dev/shm, say for a 4 gigabyte file add
                      (my server has 4GB RAM):

                      shm /dev/shm tmpfs size=4g 0 0

                      Restart your Computer!
                      --------------------------------------------------------------

                      1. 1.1. Copy 'oracle-xe-11.2.0-1.0.x86_64.rpm.zip' to /tmp
                        1.2.  Connect to your computer as 'root'
                        1.3. cd /tmp
                        1.4. unzip oracle-xe-11.2.0-1.0.x86_64.rpm.zip
                        1.5. Install necessary adds
                        apt-get install alien libaio1 unixodbc vim
                        1.6. cd Disk1
                        1.7. Create ' oracle-xe_11.2.0-2_amd64.deb
                        alien --scripts -d oracle-xe-11.2.0-1.0.x86_64.rpm
                        (ignore perl warnings!)
                        1.8. Create a 'installer chkconfig hack'
                        vi /sbin/chkconfig
                        Enter the following lines into the file:
                        #!/bin/bash

                        # Oracle 11gR2 XE installer chkconfig hack for Ubuntu
                        file=/etc/init.d/oracle-xe
                        if [[ ! `tail -n1 $file | grep INIT` ]]; then
                        echo >> $file
                        echo '### BEGIN INIT INFO' >> $file
                        echo '# Provides: OracleXE' >> $file
                        echo '# Required-Start: $remote_fs $syslog' >> $file
                        echo '# Required-Stop: $remote_fs $syslog' >> $file
                        echo '# Default-Start: 2 3 4 5' >> $file
                        echo '# Default-Stop: 0 1 6' >> $file
                        echo '# Short-Description: Oracle 11g Express Edition' >> $file
                        echo '### END INIT INFO' >> $file
                        fi
                        update-rc.d oracle-xe defaults 80 01
                        1.9. Make '/sbin/chkconfig' executable
                        chmod 755 /sbin/chkconfig
                        1.10. Define the necessary 'Oracle 11g XE kernel parameters
                        '
                        vi /etc/sysctl.d/60-oracle.conf
                        Enter the following lines into the file:
                        # Oracle 11g XE kernel parameters 
                        fs.file-max=6815744 
                        net.ipv4.ip_local_port_range=9000 65000 
                        kernel.sem=250 32000 100 128
                        kernel.shmmax=536870912
                        1.11. Setting kernel variables
                        service procps start

                        1.12. Checking fs.file-max
                        sysctl -q fs.file-max

                        1.13. ln -s /usr/bin/awk /bin/awk
                        1.14. mkdir /var/lock/subsys
                        1.15. touch /var/lock/subsys/listener

                      ------------------------------------------------------------------------
                      1.16. Install Oracle XE 11g
                      dpkg --install oracle-xe_11.2.0-2_amd64.deb
                      1.17.  Configure the Database
                      /etc/init.d/oracle-xe configure

                      1.18. su oracle
                      cd
                      1.19.  Set the Oracle Environment Variables
                      touch .bashrc
                      Write into this file the following:

                      export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe
                      export ORACLE_SID=XE
                      export ORACLE_BASE=/u01/app/oracle
                      export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$LD_LIBRARY_PATH
                      export PATH=$ORACLE_HOME/bin:$PATH

                       

                      I hope it helps

                       

                      Gerhard

                      • 8. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                        3064523

                        Hello

                         

                        I did what was suggested but Now I end up with

                        root@peter-Latitude-E6520:~# /etc/init.d/oracle-xe-18c1 configure

                        Oracle Database instance XE is already configured.

                        root@peter-Latitude-E6520:~# /etc/init.d/oracle-xe-18c1 configure

                        Specify a password to be used for database accounts. Oracle recommends that the password entered should be at least 8 characters in length, contain at least 1 uppercase character, 1 lower case character and 1 digit [0-9]. Note that the same password will be used for SYS, SYSTEM and PDBADMIN accounts:

                        Confirm the password:

                        Configuring Oracle Listener.

                        Listener configuration succeeded.

                        Configuring Oracle Database XE.

                        Enter SYS user password:

                        *********

                        Enter SYSTEM user password:

                        *****

                        Enter PDBADMIN User Password:

                        *****

                        Prepare for db operation

                        7% complete

                        Copying database files

                         

                         

                        AND NOW NOTHING HAPPENS ANY MORE

                        any Idea ?

                         

                        Thanks

                        Peter S.

                        • 9. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                          Bernhard Heidegger

                          Hi Peter,

                          I had the same issue (hanging at 7%) configuring 18c XE on Ubuntu 16.04 LTS. My investigations showed that the Oracle kernel is crashing in various libc functions, e.g. localtime()

                          I found a similar report regarding installation of Oracle Database 12c r2 on Ubuntu 18.04. The proposed solution was to remove the libc* stubs and relink oracle which is not possible with XE.

                          Since I didn't have enough time to investigate this further my solution was to switch to CentOS 7...

                          Sorry that I can't help.

                          Regards

                          Bernhard

                          • 10. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                            Marmayogi

                            It seems that you tried with rpm version of 18c. Shall I give you entire installation procedure for Ubuntu 18.04 using oracle 18c image file db_home.zip (4.3 GB)?  Are you still interested? Let me know.

                            • 11. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                              3064523

                              Hello

                               

                              It would be brillant if you could give me your Installation Information.

                               

                              I still Need to get 18EX running on ubuntu!

                              • 12. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                                3064523

                                Can this instructions also be used for Oracle 18XE ?

                                • 13. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                                  Marmayogi

                                  Method-1: Install Oracle 18c using zip file (4.3 GB):

                                  1.png

                                     You download db_home.zip file from above website which is applicable to all kinds of Linux platforms.

                                  Suppose you downloaded the file in /tmp directory. Now issue this command to unzip in directory $ORACLE_HOME:

                                   

                                  $ unzip /tmp/'Oracle 18.c LINUX.X64_180000_db_home.zip' -d $ORACLE_HOME

                                   

                                  Now begin the installation by following commands:

                                   

                                  $ cd $ORACLE_HOME/

                                  $./runInstaller

                                   

                                   

                                  Method-2: Install oracle 18c XE using rpm file (2.4 GB):

                                  3.png

                                  This rpm package can't be installed on Ubuntu. So you do convert rpm into deb using packages like alien and try to install in Ubuntu. But the general opinion is to avoid using rpm packages on Ubuntu.

                                   

                                  The answer to your question is that oracle installation was done successfully based on Method-1.

                                  The installation procedure that I propose does not support oracle18c XE edition (Method-2).

                                  • 14. Re: Try to Install Oracle 18c XE on Ubuntu Linux 18.04.1
                                    Bernhard Heidegger

                                    Hi

                                    I do appreciate your efforts to install Oracle 18c on Ubuntu but as far as I can see you installed the "full" version of the database. In this forum we're talking about the XE version specifically. For some use cases you just cannot use the full version because of licensing restrictions...

                                    Regards

                                    Bernhard

                                    1 2 Previous Next