6 Replies Latest reply on Nov 2, 2018 9:49 AM by Christian Neumueller-Oracle

    ORA-20987: APEX - Package variable g_security_group_id must be set

    3639779

      Hello,

      Recently we have moved from 4.2 to 5.1.

      When I am trying to run below query then the system is giving me an error message and it seems related to internal apex packages.

       

      Trying to execute in SQL developer:

       

      SELECT APEX_ITEM.TEXT_FROM_LOV(empno,'EMPNO_ENAME_LOV') c FROM emp;
      

       

       

      Error message:

       

      ORA-20987: APEX - Package variable g_security_group_id must be set. - Contact your application administrator.
      ORA-06512: "APEX_050100.WWV_FLOW_ERROR", line 1035
      ORA-06512: "APEX_050100.WWV_FLOW_ERROR", line 1402
      ORA-06512: "APEX_050100.WWV_FLOW_UTILITIES", line 962
      ORA-06512: "APEX_050100.WWV_FLOW_UTILITIES", line 1099
      ORA-06512: "APEX_050100.WWV_FLOW_UTILITIES", line 7429
      ORA-06512: "APEX_050100.WWV_FLOW_ITEM", line 2139
      ORA-06512: "APEX_050100.WWV_FLOW_ITEM", line 2105
      ORA-06512: "APEX_050100.HTMLDB_ITEM", line 539
      ORA-06512: line 1
      

       

      Please suggest me how to solve this issue.

       

      DB version: 12c

      Apex version: 5.1

       

      Thanks