3 Replies Latest reply on Jan 25, 2019 4:38 PM by RameshPatel

    Cloning to a new server for the first time.


      I recently refreshed (hardware & os) the server that I use for my TEST instance.


      This is my PROD server:


      Red Hat Enterprise Linux Server release 5.5 (Tikanga)


      java version "1.4.2"

      gij (GNU libgcj) version 4.1.2 20080704 (Red Hat 4.1.2-48)


      Linux coeus 2.6.18-194.26.1.el5PAE #1 SMP Fri Oct 29 14:28:58 EDT 2010 i686 i686 i386 GNU/Linux


      This the TEST server:


      Oracle Linux Server release 5.11

      Red Hat Enterprise Linux Server release 5.11 (Tikanga)


      java version "1.7.0_65"

      OpenJDK Runtime Environment (rhel- u65-b17)

      OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)


      Linux delphi.adgfi.com 2.6.39-400.215.10.el5uek #1 SMP Tue Sep 9 22:51:46 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux


      My clone was mostly successful.  My PROD environment is split tier with DB on one server and APPS on another.  For TEST, both tiers are on one server.


      adcfgclone.pl detects the platform change and does its thing


      this time around, the only issue I have is that when running adstpall.sh - three of the shutdown scripts timeout on me - forms, oacore, and oafm.


      "Error: Missing ormi[s]://<host>:<port>"


      I've already looked at ( Doc ID 414427.1  ) to no avail, so I wonder, could the problem be the difference in java versions?

        • 1. Re: Cloning to a new server for the first time.

          Please type java -version from within the applications environment.  If it is showing OpenJDK 1.7, compare your path between prod and test.  You do not require OpenJDK on your test server, so you can remove it.

          • 2. Re: Cloning to a new server for the first time.
            Hari Sankar

            Please check with other Java version if the same error is coming or not.

            Please check the  port which are already used in that server.  The port you are using should be available in that new box or shouldn't be used by other services..

            • 3. Re: Cloning to a new server for the first time.

              try the following:


              • Goto the location Oracle_Home/opmn/conf and edit opmn.xml to add a parameter -Djava.net.preferIPv4Stack=true for OC4J module as shown below.

              <process-type id=”home” module-id=”OC4J” status=”enabled”>
              < module-data>
              < category id=”start-parameters”>
              < data id=”java-options” value=”-server -Djava.net.preferIPv4Stack=true
              -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true
              < /category>
              < category id=”stop-parameters”>
              < data id=”java-options” value=”-Djava.net.preferIPv4Stack=true -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false”/>
              < /category>