9 Replies Latest reply on Nov 7, 2018 8:23 AM by Beauty_and_dBest

    Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).

    Beauty_and_dBest

      Upgrade EBS 12.2.7 to 12.2.8

      12c

      OL6

       

       

      Hi ALL,

       

      I am following  > Oracle E-Business Suite Release 12.2.8 Readme (Doc ID 2393248.1)

       

      But when I applied the patch, I got conlict below:

       

      [oratest@trnsrvr2 28500816]$ opatch prereq CheckConflictAgainstOHWithDetail -ph ./

      Oracle Interim Patch Installer version 12.2.0.1.8

      Copyright (c) 2018, Oracle Corporation.  All rights reserved.

       

      PREREQ session

       

      Oracle Home       : /u03/oratest/TEST/12.1.0

      Central Inventory : /u01/install/APPS/oraInventory

         from           : /u03/oratest/TEST/12.1.0/oraInst.loc

      OPatch version    : 12.2.0.1.8

      OUI version       : 12.1.0.2.0

      Log file location : /u03/oratest/TEST/12.1.0/cfgtoollogs/opatch/opatch2018-11-03_16-46-27PM_1.log

       

      Invoking prereq "checkconflictagainstohwithdetail"

       

      ZOP-47: The patch(es) has supersets with other patches installed in the Oracle Home (or) among themselves.

       

      ZOP-40: The patch(es) has conflicts with other patches installed in the Oracle Home (or) among themselves.

       

      Prereq "checkConflictAgainstOHWithDetail" failed.

       

      Summary of Conflict Analysis:

       

      There are no patches that can be applied now.

       

      Following patches have conflicts. Please contact Oracle Support and get the merged patch of the patches :

      25128602, 26609783, 28500816

       

      Whole composite patch Conflicts/Supersets are:

       

      Patch : 28500816

       

              Bug Conflict with Composite Patch 26609783

       

      Detail Conflicts/Supersets for each patch are:

       

      Patch : 28500816

       

              Conflict with Sub-Patch 25755742

              Conflict details:

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kspt.o

       

              Bug Superset of 24326444

              Super set bugs are:

              24326444

       

              Bug Conflict with 25128602

              Conflicting bugs are:

              19239846, 23632545, 21813400, 22666802, 24385983, 23645516, 22568797

       

              Bug Conflict with Sub-Patch 24732082

              Conflicting bugs are:

              21106027, 23220453

       

              Bug Conflict with Sub-Patch 24006101

              Conflicting bugs are:

              20627866, 21387964, 22024071

       

              Conflict with Sub-Patch 23054246

              Conflict details:

              /u03/oratest/TEST/12.1.0/lib/libgeneric12.a:kgl.o

              /u03/oratest/TEST/12.1.0/lib/libgeneric12.a:kgl2.o

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kxs.o

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kkdl.o

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kspt.o

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kkm2.o

       

              Bug Conflict with Sub-Patch 22291127

              Conflicting bugs are:

              20825533, 20936905, 21091431

       

              Bug Conflict with Sub-Patch 21948354

              Conflicting bugs are:

              20588502

       

              Bug Conflict with Sub-Patch 21359755

              Conflicting bugs are:

              20413820, 20245930

       

              Conflict with Sub-Patch 20831110

              Conflict details:

              /u03/oratest/TEST/12.1.0/lib/libserver12.a:kxs.o

       

              Bug Conflict with Sub-Patch 20299023

              Conflicting bugs are:

              19896336, 19487147, 19536415

       

              Bug Conflict with Sub-Patch 19769480

              Conflicting bugs are:

              18964939, 18674024

       

      OPatch succeeded.

       

       

      Please help...

       

      Kind regards,

      jc

        • 1. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
          mdtaylor

          Hi jc,

           

          I am not a fan of trying to apply Patch Set Updates (PSU)s to EBS instances for this very reason.  I recommend rolling back the conflicting PSU:

           

          Run the OPatch utility specifying the rollback argument as follows.

           

          opatch rollback -id 26609783

           

          Run the datapatch Utility for Standalone DB

           

          Steps Standalone DB

           

          % sqlplus /nolog

          SQL> Connect / as sysdba

          SQL> startup

          QL> quit

          % cd $ORACLE_HOME/OPatch

          % ./datapatch -verbose

           

          Then you can apply 28500816.

           

          Regards,

          Michael

          • 3. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
            Beauty_and_dBest

            Hi Michael,

             

            I already rolled back patch 26609783, but when I run checking, there is still conflicts arising with 28500816

             

            $ opatch prereq CheckConflictAgainstOHWithDetail -ph ./

            Oracle Interim Patch Installer version 12.2.0.1.8

            Copyright (c) 2018, Oracle Corporation.  All rights reserved.

             

            PREREQ session

             

            Oracle Home       : /u03/oratest/TEST/12.1.0

            Central Inventory : /u01/install/APPS/oraInventory

               from           : /u03/oratest/TEST/12.1.0/oraInst.loc

            OPatch version    : 12.2.0.1.8

            OUI version       : 12.1.0.2.0

            Log file location : /u03/oratest/TEST/12.1.0/cfgtoollogs/opatch/opatch2018-11-05_15-59-08PM_1.log

             

            Invoking prereq "checkconflictagainstohwithdetail"

             

            ZOP-47: The patch(es) has supersets with other patches installed in the Oracle Home (or) among themselves.

             

            ZOP-40: The patch(es) has conflicts with other patches installed in the Oracle Home (or) among themselves.

             

            Prereq "checkConflictAgainstOHWithDetail" failed.

             

            Summary of Conflict Analysis:

             

            There are no patches that can be applied now.

             

            Following patches have conflicts. Please contact Oracle Support and get the merged patch of the patches :

            25128602, 25755742, 28500816

             

            Whole composite patch Conflicts/Supersets are:

             

            Patch : 28500816

             

                    Bug Conflict with Composite Patch 25755742

             

            Detail Conflicts/Supersets for each patch are:

             

            Patch : 28500816

             

                    Conflict with Sub-Patch 25755742

                    Conflict details:

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kspt.o

             

                    Bug Superset of 24326444

                    Super set bugs are:

                    24326444

             

                    Bug Conflict with 25128602

                    Conflicting bugs are:

                    19239846, 23632545, 21813400, 22666802, 24385983, 23645516, 22568797

             

                    Bug Conflict with Sub-Patch 24732082

                    Conflicting bugs are:

                    21106027, 23220453

             

                    Bug Conflict with Sub-Patch 24006101

                    Conflicting bugs are:

                    20627866, 21387964, 22024071

             

                    Conflict with Sub-Patch 23054246

                    Conflict details:

                    /u03/oratest/TEST/12.1.0/lib/libgeneric12.a:kgl.o

                    /u03/oratest/TEST/12.1.0/lib/libgeneric12.a:kgl2.o

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kxs.o

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kkdl.o

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kspt.o

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kkm2.o

             

                    Bug Conflict with Sub-Patch 22291127

                    Conflicting bugs are:

                    20825533, 20936905, 21091431

             

                    Bug Conflict with Sub-Patch 21948354

                    Conflicting bugs are:

                    20588502

             

                    Bug Conflict with Sub-Patch 21359755

                    Conflicting bugs are:

                    20413820, 20245930

             

                    Conflict with Sub-Patch 20831110

                    Conflict details:

                    /u03/oratest/TEST/12.1.0/lib/libserver12.a:kxs.o

             

                    Bug Conflict with Sub-Patch 20299023

                    Conflicting bugs are:

                    19896336, 19487147, 19536415

             

                    Bug Conflict with Sub-Patch 19769480

                    Conflicting bugs are:

                    18964939, 18674024

             

            OPatch succeeded.

            [oratest@trnsrvr2 28500816]$

             

             

            Please help...

             

             

            Kind regards,

            • 4. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
              David Heisler-Oracle

              Hello,

               

              Are you attempting to apply October PSU's?  If so the ETCC for October has not been released yet.  Otherwise you may want to look into note My Oracle Support Knowledge Document 1147107.1, Database Patch Set Update Overlay Patches Required for Use with PSUs.

               

              If you don't find the appropriate overlay patch, you will need an SR to have a new patch created to resolve your conflicts.

              • 5. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
                Beauty_and_dBest

                Hi David,

                 

                I am starting from the beginning on a fresh install 12.2.7

                 

                First I run ETCC on the database and below is the result:

                 

                +===============================================================+

                |    Copyright (c) 2005, 2018 Oracle and/or its affiliates.     |

                |                     All rights reserved.                      |

                |             Oracle E-Business Suite Release 12.2              |

                |          Database EBS Technology Codelevel Checker            |

                +===============================================================+

                 

                Using context file from currently set database environment:

                /u03/oratest/TEST/12.1.0/appsutil/TEST_trnsrvr2.xml

                 

                 

                Starting Database EBS Technology Codelevel Checker, Version 120.69

                Tue Nov  6 17:48:54 PHT 2018

                Log file for this session : /u01/PATCH/ETCC/log/checkDBpatch_21705.log

                 

                Identifying database release.

                Database release set to 12.1.0.2.

                 

                Connecting to database.

                Database connection successful.

                 

                Identifying APPS and APPLSYS schema names.

                - APPS schema : APPS

                - APPLSYS schema : APPLSYS

                 

                Checking for DB-ETCC results table.

                Table to store DB-ETCC results already exists in the database.

                 

                Checking if InMemory option is enabled.

                InMemory option is not enabled in the database.

                 

                Bugfix file ./db/onprem/txk_R1220_DB_base_bugs.xml : 120.0.12020000.43

                This file will be used for identifying missing bugfixes.

                 

                Mapping file ./db/onprem/txk_R1220_DB_mappings.xml : 120.0.12020000.18

                This file will be used for mapping bugfixes to patches.

                 

                 

                [WARNING] DB-ETCC: Bugfix XML file (./db/onprem/txk_R1220_DB_base_bugs.xml) is more than 30 days old.

                Check if a newer version is available in patch 17537119.

                 

                Checking Bugfix XML file for 12.1.0.2_PSU

                 

                Obtained list of bugfixes to be applied and the list to be rolled back.

                Now checking Database ORACLE_HOME.

                DB-ETCC is compatible with this opatch version.

                 

                Found patch records in the inventory.

                 

                Checking Mapping XML file for 12.1.0.2.170814

                 

                Patch mapping not available.

                Patch mapping data is not available for 12.1.0.2 (PATCHSET UPDATE 12.1.0.2.170814)

                Refer to Doc ID 1147107.1 for the required overlay patches for PSUs and Oracle E-Business Suite

                 

                Some required one-off bugfixes are missing from the Database ORACLE_HOME.

                The missing bugfixes are:

                19509982

                20801452

                23604553

                24589081

                25099339

                25305405

                25971286

                26336977

                26654363

                26742604

                26911000

                27997875

                27547329

                 

                ** Refer to MOS Doc ID "1147107.1:Database Patch Set Update Overlay Patches Required for Use with PSUs and Oracle E-Business Suite" to find the corresponding overlay patch that delivers the bug fix. **

                 

                Apply the missing bugfixes and then rerun the script.

                 

                Stored Technology Codelevel Checker results in the database TEST successfully.

                 

                Finished checking fixes for Oracle Database: Tue Nov  6 17:49:08 PHT 2018

                 

                Log file for this session: /u01/PATCH/ETCC/log/checkDBpatch_21705.log

                 

                ===============================================================================

                 

                 

                 

                I tried to apply all the thirteen (3) missing bug fixes above but they all have conflicts

                 

                Can you guide me, How do I fix the conflicts again for all the 13 missing bug fixes?

                 

                 

                Kind regards,

                jc

                • 6. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
                  mdtaylor

                  Hi David,

                   

                  There are 3 major issues with database patching of EBS instances with PSUs applied:

                   

                  1) The 12.2.8 mandatory DB patch 28500816 is released for 12.1.0.2 only, not any PSU, and will not apply on top of any PSU

                  2) The current ETCC checker patch available this week is no longer aware of PSU patches from 2016 onward and points users to check the database overlay doc (Doc ID 1147107.1)

                  3) The database overlay doc (Doc ID 1147107.1) is no longer being updated being updated and directs users to use the latest ETCC checker

                   

                  EBS customers with 12c PSUs applied have 2 options:

                   

                  1) Create an SR to get an overlay patch created of 28500816 for the PSU they have applied and another to get an ETCC checker patch that recognizes and previous PSU

                  2) Rollback the PSU dependent patches and the PSU, then apply 28500816 on 12.1.0.2.0 plus all ETCC missing patches for 12.1.0.2.0

                   

                  I just did the latter because I didn't want to wait for the PSU dependent SRs in order to get 12.2.8 installed.

                   

                  Regards,

                  Michael

                  • 7. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
                    Beauty_and_dBest

                    Thanks Michael,

                     

                    So the same solution for my other post will apply Applying PATCH 12.2.8 (26787767) ? Meaning If I do the solution in my other post, then this issue will also be resolved?

                    Meaning hitting two birds with one stone?

                     

                     

                    Kind regards,

                    • 8. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
                      mdtaylor

                      Hi jc,

                       

                      Yes.  For now, rolling back the PSU is the best option if you do not want to wait for a few SRs to be resolved.

                       

                      Regards,

                      Michael

                      • 9. Re: Apply Database Patch 28500816 (required for Oracle Database 12.1.0.2.0).
                        Beauty_and_dBest

                        Thanks Michael,

                         

                         

                        Why has  the EBS Database been so messy lately, after they introduce this ETCC tool?

                         

                         

                        Kind regards,