0 Replies Latest reply on Nov 8, 2018 6:24 AM by debugger.pl

    Oracle SQL Developer with Kerberos authentication

    debugger.pl

      Hello, Everyone.

       

      I am working on the following configuration:

      - Windows 7 Enterprise Edition

      - JDK 8 update 192 (64-bit)

      - Oracle Database 12.2 (Kerberos Authentication)

      - Oracle Instant Client 12.2

      - Oracle SQL Developer 17.3.1

        + Use Oracle Client

        + Use OCI/Thick Driver

       

      I have noticed strange behaviour with opening connections

      Example scenarios (Kerberos authentication)

      scenario no 1

      a.  create a new connection using TNS with Kerberos Authentication unchecked

      b.  open connection – asking for username/password

      c.  test connection (connection’s properties -> Test) - success

      d.  open connection - success

       

      scenario no 2

      e.  create a new connection using TNS with Kerberos Authentication checked

      f.  open connection - success

      g.  test connection (connection’s properties -> Test) - success

      h.  open connection - success

       

      In scenario no 1 pt. b we are asked for username/password,

      next testing connection in pt. c completes with success

      and we are able to open connection in pt. d without asking for username/password

      as it should.

       

      In scenario no 2 it works as it should, which is:

      in pt. f we are able to open connection without asking for username/password,

      next testing connection in pt. g completes with success and we are able to open

      connection without asking for username/password.

       

      Is it an expected behaviour?

       

      Best Regards.

      Piotr