0 Replies Latest reply on Dec 12, 2018 12:45 AM by RedShirt01

    Start() WLST Command Fails - News at 10

    RedShirt01

      Hello!

       

      I am receiving an error when trying to use the 'start' command in WLST. Please see the error in the copy and pasted shell output as follows:

      wls:/base_domain/serverConfig> start('FooBar', 'Server', block='false')

      Starting server FooBar ...

      The server start status task for server FooBar is assigned to variable FooBarTask

       

      You can call the getStatus(), getError(), getDescription() or isRunning()

      methods on this variable to determine the status of your server start

       

      wls:/base_domain/serverConfig> FooBarTask.getError()

      weblogic.nodemanager.NMConnectException: Connection refused. Could not connect to NodeManager. Check that it is running at localhost/127.0.0.1:5556.

      wls:/base_domain/serverConfig> FooBarTask.getStatus()

      'FAILED'

      wls:/base_domain/serverConfig> nmStart('FooBar')

      Starting server FooBar ...

      Successfully started server FooBar ...

      wls:/base_domain/serverConfig>

       

      I am able to start the server with the nmStart() command. I know that NodeManager is running despite the error message because I see that the port is listening for connections using the netstat tool. Also, I connected to NodeManager with the nmConnect() method initially before trying to issue the 'start()' command. Also, if nmStart() works NodeManager is running. So, how do I resolve this error?

       

      An Internet search was not helpful. One person recommended issuing the nmEnroll() command. I tried this but this did not resolve the issue. Another person recommended connection to WLST with some SSL -D options but this also did not resolve the issue. What could be going wrong? How can I figure out a way to fix this?

       

      I am looking at the 'start()' documentation but this documentation does not explain how to configure the AdminServer for the Managed Server so that the application can connect to NodeManager for instance. The documentation I am referring to is located here: https://docs.oracle.com/cd/E12840_01/wls/docs103/config_scripting/reference.html#start

       

      Does anyone know what I would need to change for the managed server on the admin server so that the start() command works and the managed server can connect to nodemanager?

       

      I tried going here in the Admin Console: Environment -> Servers -> <Name of Managed Server> -> Configuration -> Server Start

       

      Then I added what is in the "startup.properties" file to the Arguments field. This file is under the "nodemanager" directory and specifies what arguments are needed for NodeManager to start the managed server without contacting the AdminServer. I then re-started the managed server using nmStart() because I know this way works. Next, I shutdown the server. Then after this I tried to start the server and received the same error about the AdminServer not being able to connect to NodeManager. :/

       

      I figured this out by going to Environment -> Machines -> <machine-name> -> Node Manager -> Listen Address

       

      I had to change the value for the "Listen Address" from localhost to the hostname! I saw there was more debugging information by restarting weblogic and keeping the shell open and then logging into wlst and trying to issue the start() command. For some reason there was more information printed in the log file. I think this information must normally be in the weblogic logs. 0_o

       

      Thank-you for reading this.

       

      Regards,

       

      RedShirt01