4 Replies Latest reply on Jan 4, 2019 7:18 PM by 3394270

    HBA cards showing as Not Connected

    3394270

      Please help on this.

      root@db-nightly-new:~# luxadm -e port

      /devices/pci@303/pci@1/SUNW,qlc@0/fp@0,0:devctl                    NOT CONNECTED

      /devices/pci@303/pci@1/SUNW,qlc@0,1/fp@0,0:devctl                  NOT CONNECTED

       

      root@db-nightly-new:~# fcinfo hba-port -l

      HBA Port WWN: 2100f4e9d4f7b7d0

              Port Mode: Initiator

              Port ID: 0

              OS Device Name: /dev/cfg/c2

              Manufacturer: QLogic Corp.

              Model: 7023303

              Firmware Version: 8.08.04

              FCode/BIOS Version:  BIOS: 3.40; fcode: 4.10; EFI: 6.19;

              Serial Number: 463916S+1817276607

              Driver Name: qlc

              Driver Version: 180622-5.08

              Type: unknown

              State: offline

              Supported Speeds: 4Gb 8Gb 16Gb

              Current Speed: not established

              Node WWN: 2000f4e9d4f7b7d0

              Link Error Statistics:

                      Link Failure Count: 0

                      Loss of Sync Count: 0

                      Loss of Signal Count: 0

                      Primitive Seq Protocol Error Count: 0

                      Invalid Tx Word Count: 0

                      Invalid CRC Count: 0

              Max NPIV Ports: 253

              NPIV port list:

      HBA Port WWN: 2100f4e9d4f7b7d1

              Port Mode: Initiator

              Port ID: 11500

              OS Device Name: /dev/cfg/c3

              Manufacturer: QLogic Corp.

              Model: 7023303

              Firmware Version: 8.08.04

              FCode/BIOS Version:  BIOS: 3.40; fcode: 4.10; EFI: 6.19;

              Serial Number: 463916S+1817276607

              Driver Name: qlc

              Driver Version: 180622-5.08

              Type: N-port

              State: online

              Supported Speeds: 4Gb 8Gb 16Gb

              Current Speed: 8Gb

              Node WWN: 2000f4e9d4f7b7d1

              Link Error Statistics:

                      Link Failure Count: 0

                      Loss of Sync Count: 0

                      Loss of Signal Count: 0

                      Primitive Seq Protocol Error Count: 0

                      Invalid Tx Word Count: 0

                      Invalid CRC Count: 0

              Max NPIV Ports: 253

              NPIV port list:

        • 1. Re: HBA cards showing as Not Connected
          Nik

          Hi.

          luxadm show port at state Connected when found on this link at least one target.

           

          You have 2 FC port.

          /dev/cfg/c2 - ofline

          /dev/cfg/c3 - online 8 Gb/s

           

          Check zonning on FC-switch.

          Regards,

             Nik.

          • 2. Re: HBA cards showing as Not Connected
            3394270

            Hi Nik,

             

            I checked zoning and looks good to me.

             

            alias:    db_nightly_new   

                    21:00:f4:e9:d4:f7:b7:d0; 21:00:f4:e9:d4:f7:b7:d1

            alias:    corp_flash4   

                    50:05:07:60:5e:90:56:81; 50:05:07:60:5e:90:56:91;

                    50:05:07:60:5e:90:56:a1; 50:05:07:60:5e:90:56:b1

            zone:    db_nightly_new_corp_flash4   

                    21:00:f4:e9:d4:f7:b7:d0

                    21:00:f4:e9:d4:f7:b7:d1

                    50:05:07:60:5e:90:56:81

                    50:05:07:60:5e:90:56:91

                    50:05:07:60:5e:90:56:a1

                    50:05:07:60:5e:90:56:b1

             

            Please suggest.

            • 3. Re: HBA cards showing as Not Connected
              Nik

              Hi.

              How many FC-switches ( SAN) you have ?

              Port c2 - have state offline.  But you configure it at zones.   Is this port connected to switch ?

              You configure  zone db_nightly_new_corp_flash4. Is this zone part of active configuration ?

               

              alishow  on switch will show what configuration is effective and what zones included at this config.

               

              Show on server side result of command :  cfgadm -al -o show_FCP_dev

              Regards,

                Nik

              • 4. Re: HBA cards showing as Not Connected
                3394270

                Thanks for all your support Nik. It's the issue with Zoning. I am also setting up a new storage so facing these issues. Now I am on track.

                 

                -Prakash