2 Replies Latest reply on Jan 16, 2019 4:54 PM by Blue Bird

    Function is "Compiled for Debug" by default in SQLDev 18.3

    Blue Bird

      Hello,

       

      I'm noticing strange behaviour in SQLDev 18.3. I'm connected on remote Oracle 12.2.0.1 x64 Win database using SQLDev 18.3. When I compile Procedure or Function this program is always Compiled for Debug by default (I see green icon in front of compiled object) - see below:

      If I later click on this TEST183 and then directly click button for compile or use Ctrl+Sh+F8 (with gears) is still compiled for Debug. But, if I click on drop down button and select Compile or press Ctrl+F8, then compiled as release version. It's look like that direct click without open dropdown button use icon for Compile but actually execute Compile for Debug action.

      If I run the same script on SQLDev 18.2 code is compiled normally (not for debug) as release - see above TEST182. Also if I run the same code on this server locally using SQLDev 18.3 also all work fine.

      In Preferences > Shortcut Keys I have below settings. I also tried also to use Use Keyboard Scheme and load Default if maybe would help but it doesn't.

       

      What could be a reason for this strange behaviour and how to fix it?

       

      BB