2 Replies Latest reply on Jan 31, 2019 6:17 PM by user9180905

    SQL Dev - No Connection Type Available

    user9180905

      This issue started in v17.4 and after downloading the new 18.4 I'm still getting the same issue. When I go to add or edit a new DB connection, I get this error:

           Could not load connection type:Oracle

       

      And then the window that follows (the usual "New / Select Database Connection") is blank under the Name/Un/Pw boxes; so where you would have an Oracle tab to enter the connection specifics into.

       

      The program starts fine, I can open and work in the existing connections no problems.

       

      I'm on version 18.4.0.376-1900 with JRE 1.8.0_181 (built in, I downloaded the package with it included) running under Windows 7.

       

      Can't seem to find any useful information on the web, so i thought I should try the source!

        • 1. Re: SQL Dev - No Connection Type Available
          Glen Conway

          Whenever something exceptionally frustrating happens like you describe above, the tendency is to blame the user settings. 

           

          Have you tried renaming (assuming Windows) your C:\Users\<your_userid>AppData\Roaming\SQL Developer\system18.4.0.376.1900

          folder to something else, then restarting SQL Developer and skipping the user settings migration step?   If not, do so and see if the Oracle tab reappears in the "New / Select Database Connection" dialog.

           

          If it works, then hopefully you have an export file of your connections from some recent version of SQL Developer to import.

          1 person found this helpful
          • 2. Re: SQL Dev - No Connection Type Available
            user9180905

            Dang. That was too easy. I tried a handful of other things but not that. Worked like a charm, thanks so very much for this!

             

            Alan