6 Replies Latest reply on Feb 13, 2019 7:33 PM by BlackWolfDesign

    apex and apache-config problem?

    BlackWolfDesign

      Hi i wanted to install apex on my ubuntu system. (APEX 18.2, ORDS 18.4, ORACLE-XE 18C)

       

      i used this docker-"images":
      https://github.com/fuzziebrain/docker-oracle-xe

      https://github.com/martindsouza/docker-ords

       

      but when i go to my apex site,i get an unnormally page-"construction"...

       

      apex.png

       

      i dont know why

       

      ords-logs:
      Feb 09, 2019 4:10:07 PM

      WARNING: *** jdbc.MaxLimit in configuration |apex|| is using a value of 10, this setting may not be sized adequately for a production environment ***

      Feb 09, 2019 4:10:07 PM

      WARNING: *** jdbc.InitialLimit in configuration |apex|| is using a value of 3, this setting may not be sized adequately for a production environment ***

       

      apache2-conf:

      <VirtualHost *:80>

        ServerName apex.naffs.de

        RewriteEngine on

        RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI}# [L,NE,R=permanent]

       

        ProxyPass / http://127.0.0.1:32514/

        ProxyPassReverse / http://127.0.0.1:32514/

        ProxyPreserveHost On

        ProxyAddHeaders On

        RequestHeader set X-Forwarded-Proto "http"

      </VirtualHost>

       

       

      <VirtualHost *:443>

        ServerName apex.naffs.de

       

        # You should proxy to a plain HTTP session to offload SSL processing

        ProxyPass / http://127.0.0.1:32514/

        ProxyPassReverse / http://127.0.0.1:32514/

        ProxyPreserveHost On

        ProxyRequests Off

        ProxyAddHeaders On

        RequestHeader set X-Forwarded-Proto "https"

       

        ProxyPass /apex htpp://localhost:32514/apex

        ProxyPassReverse /apex http://localhost:32514/apex

        ProxyPass /i http://localhost:32514/i

        ProxyPassReverse /i http://localhost:32514/i

       

        SSLProxyEngine On

        SSLCertificateFile /etc/letsencrypt/live/apex.naffs.de-0002/fullchain.pem

        SSLCertificateKeyFile /etc/letsencrypt/live/apex.naffs.de-0002/privkey.pem

        Include /etc/letsencrypt/options-ssl-apache.conf

      </VirtualHost>

       

      docker ps:

      1ff8fc6ac512        ords:18.4.0              "/ords/config-run-or…"   28 minutes ago      Up 28 minutes (healthy)   0.0.0.0:32514->8080/tcp                                                                                                                      ords

      1e2a986a2c4a        oracle-xe:18c            "/bin/sh -c 'exec ${…"   4 hours ago         Up 4 hours (healthy)      0.0.0.0:32118->1521/tcp, 0.0.0.0:35518->5500/tcp                                                                                             oracle-xe

       

       

      Did I overlook the following?... (maybe i set it to 1?)
      Enter 1 if using HTTP or 2 if using HTTPS [1]: