3 Replies Latest reply on Mar 26, 2019 12:55 PM by Madhusudhan.Meesala

    Install patch failed

    Bill252

      Hello,

       

      Someone already had this behavior, I try to patch an environment on which is installed EAS, APS, WORKSPACE, FOUNDATAION, OHS, CALC.

      Some patches have been installed, but EAS patch 27397238, I get this message:

      ###############################
      OPatch will do the following:
      [Oracle Home Discovery]: Configure and Validate Oracle Home Info.
      [Prerequisite for apply]: Invoke prerequisites to see if patch can be applied.
      [Patch conflict detection for patch]: Check if any conflict with already installed patches in Oracle Home.

      ApplySession applying interim patch '27397238' to OH '/ apps / epmvinr1 / Oracle / Middleware / EPMSystem11R1'

      Running prerequisite checks ...
      Prerequisite check "CheckPatchApplicableOnCurrentPlatform" failed.
      The details are:
      Patch (27397238) is not applicable on current platform.
      Platform ID needed is: 211
      Platform IDs supported by patch are: 226
      [Error during Prerequisite for Apply Phase]. Detail: OPatch failed during prerequisite checks: Prerequisite check "CheckPatchApplicableOnCurrentPlatform" failed.
      System is intact, OPatch will not restore the system

      Recommended actions: This patch requires some components to be installed in the home. Either the Oracle Home does not have the components or this patch is not suitable for this Oracle Home.

      #######################

       

      Impact: Unable to connect to EAS, it is blocked by JAVA security as if it were a non-certified product.

       

      Thank You for you return

        • 1. Re: Install patch failed
          JohnGoodwin

          Are you sure you have download the patch for the correct OS and 64bit, opatch does not think so.

           

          Patch (27397238) is not applicable on current platform.

          Platform ID needed is: 211

          Platform IDs supported by patch are: 226

           

          If you believe it is correct then you may need to set an environment variable for it to apply, there are lots of support docs available, for example Failed To Apply Patch Opatch Detects Platform 46 While Patch Is For 226 (Doc ID 337812.1)

           

           

          Cheers

           

          John

          • 2. Re: Install patch failed
            Bill252

            Hello John,

             

            Thank you for your return and for the link of the Doc.
            The patch is good because it has already been applied to other envionnement.

             

            Thank

             

             

            • 3. Re: Install patch failed
              Madhusudhan.Meesala

              Patch (27397238) is not applicable on current platform.

              #######################

              Recommended actions: This patch requires some components to be installed in the home. Either the Oracle Home does not have the components or this patch is not suitable for this Oracle Home.

              Impact: Unable to connect to EAS, it is blocked by JAVA security as if it were a non-certified product.

               

              Thank You for you return

              Check out, you are applying patch with correct Oracle home path or not. Check out that recommended action saying that some components to be installed, so check out for any prerequisites for this patch.

               

              Thanks,

              Mady