2 Replies Latest reply on Mar 29, 2019 2:00 PM by DanyB

    Need help with HFM taskflow error

    DanyB

      Hi experts,

       

      I'm hoping someone out there will be able to help me out with a strange one. Edit: The question is kind of long, but I tried to put most of the information I got in there.

       

      We use a taskflow in HFM (11.1.2.4.000_26950214 - seems like an odd number) to run some allocation. The steps are as follow:

       

      Step 1 - Calculate the hierarchy of the consolidation tree that we use for the allocation (E#SEGMENT)

      Step 2 - Allocate by running through every base entity of SEGMENT

      Step 3 - Consolidate All With Data SEGMENT

       

      It's always been working fine.

       

      Cue to the beginning of 2019. A new entity was created in our group (E#NewCo). Following this, a new scenario (Scenario 2) and a new consolidation tree (E#SEGMENT2) were also created. So I now have this:

       

      Scenario 1 - SEGMENT (NewCo isn't a part of this tree)

      Scenario 2 - SEGMENT2 (NewCo is a part of this tree)

       

      I created a second taskflow to allocate data on SEGMENT2. The steps are the exact same as the first taskflow. The POV is also the same except for the scenario and the consolidation tree. The first one is still working fine, but the second one gives me an error at the end of Step 2.

      In System Messages, I get this:

      And of course, the following that makes the source of the error crystal clear:

       

      Now I used WriteToFile in the rules file to try and see where it all goes wrong, and it seems like the allocation runs through every entity like it should (including NewCo), then something happens and bang, everything stops.

       

      So if anyone has any idea why this happens or where I should look, please help me out!

        • 1. Re: Need help with HFM taskflow error
          CBarbieri

          In terms of which version you're on, I think it's 11.1.2.4.207, based on the code number in the error message. I don't know if that's relevant however.

           

          What happens if you run the task flow steps manually, from a grid inside HFM?

           

          Keep in mind there are two objects that can generate vbscript errors: Rules, which is the issue 99% of the time, and custom member lists. Is it possible you have an error in a member list? To run the list, just go into a POV somewhere, select the list and show the members. If you get an error displaying the members, then the error lies with the list.

           

          You said you used WriteToFile to debug the rules. Which subroutine was the last to successfully run? You should be able to see which entity-value-major subroutine was running when it failed.

          1 person found this helpful
          • 2. Re: Need help with HFM taskflow error
            DanyB

            Thanks Chris!

             

            I did what you suggested, ran the various tasks from a grid, and I was able to pinpoint the problem. Everything works fine now.