8 Replies Latest reply on Aug 15, 2019 9:17 AM by Just_UD

    Failed to run rapidwiz

    Just_UD

      Hello,

       

      I would like to ask an issue that I'm currently facing. I downloaded EBS 12.1.3 from edelivery.oracle.com and put in Oracle Enterprise Linux 7 update 6. After downloaded, I extracted the files then I ran rapidwiz.sh. However, I got an error like this:

       

      ./rapidwiz: /bin/sh^M: bad interpreter: No such file or directory

       

      What's the cause of the error and how to fix it?

       

      Is it true that patch 11072566_R12_GENERIC must be use instead of the original download? I downloaded that patch, overwrite the previous extracted program from edelivery then ran rapidwiz. This time the installation window appear (however some of the texts were cut) but when I continue the process I got alert like this:

       

      RW-20019: No install actions have been found for this machine. Continue on to other uninstalled machines in your configuration, or

       

      If I only browse to find the error message, it said something to do with /etc/hosts file. Problem is I already setup the hostname and domain.

       

      So how do I continue?

       

      Thanks

        • 1. Re: Failed to run rapidwiz
          pmkr

          Ahh .. I faced exactly the same issue with EBS R12.1.3 in Linux 7. This is due to the file format, which is in dos. If you opened the file rapidwiz, you would've noticed, it would display "rapidwiz.bak" [dos] at the bottom left corner of the editor. This is still in the dos format, which adds additional ^M (control-m or newline) character at the end of each line.

           

          I converted it to unix format using the dos2unix tool. THIS script worked, but, there's the other script "startCD/Disk1/rapidwiz/bin/runWizard.sh" which's called from rapidwiz is failing with the same error.

           

          I can convert that too. But I don't know how many files need such conversion.

           

          I've no idea about the patch you mentioned.

           

          Perhaps, an SR should be opened to clarify both.

           

          Thanks

          Muthu

          • 2. Re: Failed to run rapidwiz
            Just_UD

            Yes, I've created a technical SR and will update later

            • 3. Re: Failed to run rapidwiz
              Just_UD

              I've just got reply from Oracle Support and he/she told me to install version 12.1.1 then upgrade to version 12.1.3 as per document 2457130.1

               

              Download and use files under "DLP: Oracle E-Business Suite 12.1.1.0.0".
              The ones marked for certified configuration such as "DLP: Oracle E-Business Suite Certified Configuration 12.1.3" are available for Oracle Internal Service, and are not intended for use by customers.

              1 person found this helpful
              • 4. Re: Failed to run rapidwiz
                pmkr

                Thanks. Me too did the same. Support analyst said that the s/w I downloaded is not the correct version. I'm in the process of upgrading from 11.5.10.2 to 12.1.3. Support engineer said that, I can't directly upgrade to 12.1.3, rather we should first upgrade to 12.1.1 and install the 12.1.3 RUP on top of that, to bring it to 12.1.3.

                 

                So, one should search for "Oracle Financials" in the edelivery.oracle.com and not "Oracle E-Business Suite" (though, that's what I did first and I've no clue, why "Oracle Financials", lol) and then download the 12.1.1 s/w from there.

                 

                That's what I did and it worked like charm. In fact, In a couple of forum threads, some Oracle engineers mentioned exactly the same. ie. search for "Oracle Financials" and pick up the E-Bus 12.1.1 s/w from there. But those threads were about 6-7 years old and I thought it may not be relevant now, but surprisingly it is.

                 

                Thanks

                Muthu

                • 5. Re: Failed to run rapidwiz
                  Just_UD

                  Hi Muthu,

                   

                  Did you experience problem when you upgrade to 12.1.3? I'm trying to install 12.1.1 but always failed because I'm using Oracle Linux 7 and they came with unzip-6 instead of unzip-5. I tried to rename the program location where instead of /usr/bin/unzip I changed it to /usr/bin/unzip6. After that I tried to install unzip 5 but failed with the following error:

                  rpm -ivh unzip-5.52-3.0.1.el5.x86_64.rpm

                  warning: unzip-5.52-3.0.1.el5.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 1e5e0159: NOKEY

                  Preparing...                          ################################# [100%]

                      package unzip-6.0-19.el7.x86_64 (which is newer than unzip-5.52-3.0.1.el5.x86_64) is already installed

                      file /usr/bin/funzip from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/bin/unzip from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/bin/unzipsfx from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/bin/zipgrep from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/bin/zipinfo from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/share/man/man1/funzip.1.gz from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/share/man/man1/unzip.1.gz from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/share/man/man1/unzipsfx.1.gz from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/share/man/man1/zipgrep.1.gz from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                      file /usr/share/man/man1/zipinfo.1.gz from install of unzip-5.52-3.0.1.el5.x86_64 conflicts with file from package unzip-6.0-19.el7.x86_64

                  • 6. Re: Failed to run rapidwiz
                    Just_UD

                    If I tried to uninstall unzip-6 then I got these errors:

                     

                    rpm -e unzip-6.0-19.el7.x86_64

                    error: Failed dependencies:

                        unzip is needed by (installed) systemtap-client-3.3-3.el7.x86_64

                        unzip is needed by (installed) rpm-build-4.11.3-35.el7.x86_64

                        /usr/bin/unzip is needed by (installed) file-roller-3.28.1-2.el7.x86_64

                    • 7. Re: Failed to run rapidwiz
                      Kanda-Oracle

                      Hi

                       

                      Can you check whether the file was downloaded without any issues.

                       

                      Thanks!

                      • 8. Re: Failed to run rapidwiz
                        Just_UD

                        Hi, the file was downloaded without any issues. Have checked but I'd raised an SR and the support staff suggest me to download other packages. After that everything worked well.