0 Replies Latest reply on Apr 30, 2019 4:03 PM by user1121029

    OCC Adapter in ICS

      I’m having an issue with the OCC GetOrder api in OIC. At one point the api was working correctly as returning all the elements. Something has changed and now shippinggroups is no longer returned. I'm sure this is a metadata issue since I have an old integration which returns shippinggroup. When I clone it and refresh the metadata then shippinggroups is not longer returned.




      When I call the OCC API directly then shippinggroups is returned as expected.


      At present I have tried the following but it is still not returning the shippinggroups as aspected for GetOrder:

      - Checked the metadata-catalog and GetOrder contains shippinggroup as expected.

      - Have created a new OCC connection

        - Also Refreshed Metadata on the new connection

      - Created a new basic integration based on the above connection

        - Has also regenerated the endpoints on the integration



      I’m pretty convinced that OCC is not to blame here. Can anyone see what I am missing? It’s appears that OIC is not managing to get the correct definition.
      Any help would be appreciate. I’m hoping there’s a simple answer to this.