9 Replies Latest reply on May 14, 2019 2:02 AM by Glen Conway

    Error Message = ORA-01017: invalid username/password; logon denied

    67409fdf-0a58-47f2-9ddd-fba6474aa8de

      Hello Oracle Community,

      I'm new with Oracle. This is my first post in Oracle forum. I am learning oracle about a month. I apologize if I use wrong keywords. Today I encountered with a weird error. Let me explain the whole scenario.

      As I say I'm learning oracle about a month. I have bee using Oracle SQL Developer instead of command prompt. It has been working great. Last a couple of days I have learning some PL/SQL. Yesterday I switched to windows command prompt. It was not letting to login there, after 3,4 hours of hardwork, I changed the password from sql developer then tried to login from command prompt and let me logged in in first attempt.

      Today I went back to SQL developer. All sql statements are working fine. but it doesn't not show me any PL-SQL output. When I enter the same statement in command prompt, it gives me the out put. I closed command prompt, restarted sql developer, but still doesn't work, the only out put it show me "PL/SQL procedure successfully completed.". Here is the example of PL-SQL block.

      set serveroutput on

      begin

      dbms_output.put_line('Welcome to Oracle');

      end;

      The weird thing is that i can use all sql statement, I just created a new table, retrieves data from old tables.

       

      I use disc command in sql developer, it give me confirmation that disconnected, but when I type show user, it will show me SYSTEM. I tried to re-connect and it gives me error;

      Error starting at line : 1 in command -

        connect ...

      Error report -

      Connection Failed

        USER          =

        URL           = jdbc:oracle:thin:@localhost:1521:xe

        Error Message = ORA-01017: invalid username/password; logon denied

      Commit

       

      I changed the password to "Password" yesterday. I can successfully login for command prompt and use PL-SQL blocks there but not in sql developer. I'm helpless and don't know what happens and why it's not working. I'm also enclosing a screen shot. Please help me. I would really appreciate that.

      Thanks

      Sha

       

      PL_SQL.PNGcommand prompt.PNG