3 Replies Latest reply on May 22, 2019 11:47 AM by HansJK

    Design in "SVN working copy" is broken and being eaten/corrupted on saving?

    HansJK

      Hi

       

      Using:  Standalone SDDM 18.4 (64-bit Java)  on Windows 10 (Pro).

       

      I previously asked about SVN functionality in that it was not bringing or showing "Incoming Changes".  Using SVN - Incoming Changes not updating/showing or taking much too long?

       

      Now I am done with SVN?  I have had to get my design out of the working copy and saved into a non-versioned folder.

      The reason for this?

       

      It started with 'corruptions' in the design where "remote objects" links were being 'lost'/broken.

      (These "remote objects" are all in the same design, just in separate Relational Models.  We have a Relational model per DB Schema.)

      e.g.

      2019-05-17 01:02:36 SEVERE - DesignObject.updateFromRemoteObject -file for remote object doesn't exist:
       Remote:D:\Oracle_SDM_DataModels\ooba_Platform\op_Single_DM.orig.now.broken\oobaPlatform\rel\15F538DB-6F4BACC2332C\table\seg_0\9D96F717-CD0B-AD91-C695-A98EB306A347.xml
       Local:D:\Oracle_SDM_DataModels\ooba_Platform\op_Single_DM.orig.now.broken\oobaPlatform\rel\2D63BC31-413A9C9E6279\table\seg_0\4A2C6260-89C7-F370-D7DB-A1DF99234B6B.xml
      

       

      I managed to fix these types of issues by removing the remote object and re-adding it to the respective Relational Model.

       

      Then I started getting errors whenever I saved the design and had made a change in a relational model.

       

      The (external) log will show:

      2019-05-18 15:05:22 SEVERE - Can not write data! Location: D:\Oracle_SDM_DataModels\ooba_Platform\op_Single_DM\oobaPlatform\rel\2D63BC31-413A9C9E6279\subviews\.xml - Name: OP_FND
      java.lang.NullPointerException
      at oracle.dbtools.crest.fcp.vcs.VCSClientHelper.isDmPropertiesChanged(VCSClientHelper.java:1774)
      at oracle.dbtools.crest.fcp.vcs.VCSClientHelper.saveProperties(VCSClientHelper.java:804)
      at oracle.dbtools.crest.fcp.vcs.VCSClientHelper.saveProperties(VCSClientHelper.java:746)
      at oracle.dbtools.crest.fcp.vcs.VCSClientHelper.saveProperties(VCSClientHelper.java:733)
      at oracle.dbtools.crest.fcp.vcs.VCSClientHelper.saveProperties(VCSClientHelper.java:706)
      at oracle.dbtools.crest.model.metadata.XMLTransformationManager.saveObject(XMLTransformationManager.java:1591)
      at oracle.dbtools.crest.model.metadata.XMLTransformationManager.saveDiagrams(XMLTransformationManager.java:1880)
      at oracle.dbtools.crest.model.metadata.XMLTransformationManager.saveDesign(XMLTransformationManager.java:409)
      at oracle.dbtools.crest.model.design.Design.saveAll(Design.java:2162)
      at oracle.dbtools.crest.swingui.ControllerApplication.saveAll(ControllerApplication.java:4041)
      at oracle.dbtools.crest.swingui.ControllerApplication.saveDesign(ControllerApplication.java:3021)
      at oracle.dbtools.crest.swingui.ControllerApplication.access$6100(ControllerApplication.java:120)
      at oracle.dbtools.crest.swingui.ControllerApplication$SaveAll$1.run(ControllerApplication.java:2933)
      
      

       

      I tried to work through this, but it would not stop.

      The file (mentioned in the error) is the one in which the 'base' relational model is saved.  I have many sub-views and they are of course in same location.

       

      In desperation I saved the design into a non-versioned location.  Now there are no such errors/issues.

       

      1. Is my design now corrupted and I should not trust it anymore?
      2. Should I stay away from SVN and hence try and safe guard the design in some other way?
        Bummer that collaborative work is then not possible.
      3. I have tried editing the design using SDDM 17.4.
        While in the "SVN working copy" location I get the same error as above.
        Does this mean the design is now not to be trusted?

      I have been a big proponent/advocate for SDDM since version 3. 

      This is a growing design and it would be a real killer if it was 'lost'.

       

      Please help me figure out what is going on here?