1 Reply Latest reply on May 29, 2019 12:30 PM by BluShadow

    Discoverer report  is not working in users machine but it is working on mine

    4f6becc4-afb3-49a3-abf4-33eaafd44cf5

      Hi All,

       

      Need help.

      We have one report in Discoverer when we are running it in any machine it is working fine except Sweden user machine.

      When we are running the report at Sweden machine we are receiving error -ORA 01722.

      We checked the conversion of string to numeric but it is fine.

       

      Thanks,

      Purnachandu S

        • 1. Re: Discoverer report  is not working in users machine but it is working on mine
          BluShadow

          4f6becc4-afb3-49a3-abf4-33eaafd44cf5 wrote:

           

          Hi All,

           

          Need help.

          We have one report in Discoverer when we are running it in any machine it is working fine except Sweden user machine.

          When we are running the report at Sweden machine we are receiving error -ORA 01722.

          We checked the conversion of string to numeric but it is fine.

           

          Thanks,

          Purnachandu S

           

           

          Well, obviously it's not, otherwise Oracle wouldn't complain.

           

          How is the conversion being done?  Is it considering local numeric formats?  or perhaps expecting a specific format that "looks fine" to yourself, but you don't realise that other countries use different formats?

           

          e.g. in the UK, we use a comma "," as the thousands separator and a period "." as the decimal separator.  In some other countries they are the other way around.