1 2 Previous Next 16 Replies Latest reply on Jun 6, 2019 1:12 PM by _Dylan_

    MKS Toolkit Tip of the Day

    _Dylan_

      When using 19.1, every once in a while (randomly when saving files I think) I'll get "Tip of the Day" popup with a picture of an MKS Toolkit Software box. Is this something embedded within SQL Developer?

        • 1. Re: MKS Toolkit Tip of the Day
          thatJeffSmith-Oracle

          Can you please share a screenshot next time you see it?

           

          I don't know of that as a feature.

           

           

           

          Tip of the day was in the product MANY years ago.

          • 2. Re: MKS Toolkit Tip of the Day
            _Dylan_

            I will. I'm assuming that since I've said something, it will never happen again.

            • 3. Re: MKS Toolkit Tip of the Day
              _Dylan_

              It didn't happen all day. Remembered that I also turned off the Welcome Page on Startup this morning. Turned it back on, restarted, edited a file I was working on earlier, (Alt-F S) to save, and *poof*, it poped up the first time. It doesn't happen consistently though. Nothing else was running at the time, and I can't interact with SQL Developer until I close it...so I don't think it was something in the background prompting me.

               

              tip_of_the_day.png

              Edit: Seems that it only happens the first time a file is saved, and then it doesn't happen until SQL Developer is restarted.

              • 4. Re: MKS Toolkit Tip of the Day
                Glen Conway

                If you download SQL Developer 3.2.2, which I believe is the last release to include "Tip of the Day", and move through all the tips, you won't see any tip about MKS Toolkit.

                https://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/sqldev-downloads-v322-2080107.html

                 

                Have you added any Java-based User Defined extensions?  That might be the only kind of thing I can imagine that would be capable of making SQL Dev display such an unlikely tool tip.  Unless your 19.1 download was not from the Oracle site, and you got something someone hacked.  Yeah, hope it won't happen again.

                 

                Cheers

                1 person found this helpful
                • 5. Re: MKS Toolkit Tip of the Day
                  Glen Conway

                  Wow!  You win the prize for weird with that Tip of the Day image.  That must be from an extremely old SQL Dev release.  Here is the one from 3.2.2

                  Capture.JPG

                  • 6. Re: MKS Toolkit Tip of the Day
                    _Dylan_

                    I have Show Me Password (from TomeCode | Show Me Password extension for Oracle SQL Developer and JDeveloper ) and a DB2 JDBC driver installed. If I remove both, I still get the popup. It's also independent of the Welcome Page showing on startup or not.

                    • 7. Re: MKS Toolkit Tip of the Day
                      Glen Conway

                      Very interesting. As a test, you can try exiting SQL Developer, renaming your user settings directory (system19.1.0.094.2042) to something else, then

                      start up SQL Developer so you get a fresh setting of user settings.  You can get the default values, or migrate the settings from a prior result.

                       

                      And by the way, even going back as far as 1.5.1, the Tip of the Day dialog does not include a left-side with a product image.  Here it is, including the Next Tip and Close buttons

                      Capture151.JPG

                      So it seems that the tips from that other product are showing in SQL Developer somehow, probably from something a user extension install did (and the uninstall did not do?).   If I try your test case of editing a file, then saving it with Alt-F S, it just saves it without any tip popping up.

                      • 8. Re: MKS Toolkit Tip of the Day
                        thatJeffSmith-Oracle

                        that's not our code

                        • 9. Re: MKS Toolkit Tip of the Day
                          _Dylan_

                          Any thoughts on narrowing down what it might be? Did a fresh unzip of the 19.1 w/ JDK to a different directory. Get the same thing with that one as well. Only seems to happen when I try to save a file in SQL Developer and not elsewhere. Do plugins get installed somewhere outside the directory that the new copy of SD would be accessing it?

                          • 10. Re: MKS Toolkit Tip of the Day
                            _Dylan_

                            Looks like it is/was maybe git related? Cleared the log just before saving and ended up with:

                               

                            LevelSequenceElapsedSourceMessage
                            INFO117337oracle.dbtools.raptor.utils.JawsUtilNbMainWindow AccessibleDescription Logging Page
                            INFO11724911oracle.dbtools.raptor.utils.JawsUtilNbMainWindow AccessibleDescription Logging Page - Log
                            INFO11711org.netbeans.core.startup.NbEvents

                            org.netbeans.libs.jna.platform/1 [1.15 201702060959]

                            org.netbeans.libs.jsch.agentproxy/1 [0.15 201702060959]

                            org.eclipse.jgit [3.6.2 3.6.2.201501210735-r]

                            com.jcraft.jsch [0.1.54 0.1.54]

                            org.netbeans.libs.git/1 [1.34 201702060959]

                            com.jcraft.jzlib [1.0.7 1.0.7]

                            com.googlecode.javaewah.JavaEWAH [0.7.9 0.7.9]

                            INFO1170112org.netbeans.core.startup.NbEventsTurning on modules:
                            INFO11694651org.netbeans.NetigsoLoaderOSGi is requesting adhoc start of org.netbeans.libs.git. This is inefficient. It is suggested turn the module on by default

                             

                            Saw git so I disabled and restarted, no more popup. Turned git back on, still no popup, and no additional events in the log beyond me clicking on the file.

                            • 11. Re: MKS Toolkit Tip of the Day
                              Glen Conway

                              Did a fresh unzip of the 19.1 w/ JDK to a different directory. Get the same thing with that one as well.

                              Even if you install a specific version of SQL Developer into multiple directories, all of those installs will still use the same user settings (in C:\Users\<yourUserId>\AppData\Roaming\SQL Developer\system<versionNum>) unless you override it by adding a line like

                              AddVMOption -Dide.user.dir=<override_user_settings_location>

                              in the sqldeveloper.conf file of the install.  You can check what you actually use in the Help > About > Properties tab

                              Capture.JPG

                              1 person found this helpful
                              • 12. Re: MKS Toolkit Tip of the Day
                                Glen Conway

                                Glad you got it to work.  Out of curiosity, exactly what do you mean by "disabled" in

                                Saw git so I disabled and restarted, no more popup.

                                In the Tools > Features, my GIT is enabled, but I have no local GIT repository

                                Capture.JPG

                                If that is all you disabled, then the problem is still likely related to a User Defined extension, not one of the standard bundled features.  Still, this was an interesting (having gone well past) lunch time distraction.

                                • 13. Re: MKS Toolkit Tip of the Day
                                  _Dylan_

                                  In the features window you took a screenshot of, I unselected Git -> Applied Changes -> Restarted. The files I'm editing when getting the popup are in a local repo. I went back to check 18.4 and it's happening there. Seems it's only when editing a file in a git repo. If I start a new worksheet, put in some garbage, save it outside of a repo...no popup. Switch over to one of the repo files, edit and save...popup. Restart, and edit that first garbage file and save again...no popup.

                                  • 14. Re: MKS Toolkit Tip of the Day
                                    Glen Conway

                                    Thanks for the information.  That use case should be helpful to anyone able to follow-up on the issue.  Since I don't use git, it won't be me, but it must be annoying to you, so best wishes on getting a fix or workaround that does not require disabling git.

                                    1 2 Previous Next