2 Replies Latest reply on Jun 6, 2019 2:25 PM by Arilden

    Loding ords.war in Glassfish, Error: oracle.dbtools.common.di.DependencyInjectionException

    Arilden

      Setup:

      Fresh install.

      • Windows Server 2016
      • Oracle DB 18c
      • Apex 19.1
      • Ords 19.1
      • Java jdk-8u211
      • Tried Glassfish 4 and 5

      Fails to upload ords.war to Glassfish, get this Error:

       

      Error occurred during deployment: Exception while loading the app :

      java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException:

      oracle.dbtools.common.di.DependencyInjectionException: Could not invoke: oracle.dbtools.injector.impl.InstantiatorsImpl$ReflectiveInstantiator@45b396eb

      , due to the following error: java.lang.IllegalAccessError: tried to access class com.google.common.collect.Platform from class com.google.common.collect.MultimapBuilder$LinkedHashSetSupplier.

      Please see server.log for more details

       

      Any idea what is causing the error.

      Arild