0 Replies Latest reply on Jun 6, 2019 11:48 AM by user10281735

    Starting a managed server with a different JVM

    user10281735

      We are migrating from WebLogic 10.3.3 to WebLogic 12.2.1.3 but are having some issues in testing our deployed applications which have been built with Java 1.6.0_29 (The WebLogic domain is using Java 1.8.0_191).

      We do not wish to upgrade the applications to a higher version of Java if possible - they are legacy applications.

      Is it possible to run a Java 6 application on WebLogic 12.2.1.3? We are getting 'unsupported major.minor version' errors at points within the applications (see attached image).

       

      It was suggested to try running the managed servers using Java 6.

      However, after changing the server start 'java home' and 'classpath' properties to point to Java 6, the managed servers continue to start with Java 1.8.0_191.

      I can't figure out why? Does the nodemanager also need to be running on Java 6?