2 Replies Latest reply on Jun 10, 2019 11:26 PM by Glen Conway

    java.lang.NullPointerException when exporting result set to file (SQL Developer 19.1)

    7c5ec225-7fb1-4ad7-bb25-5b1e605dc394

      When attempting to export a result set of a query I am receiving the following errors:

       

      Utilities - Log:

      ** Export Start ** at 2019.06.10-14.38.52

      Export Single File to C:\Users\z09999.ZBC\export.xlsx

      **Exception** : Check Logging Page

      **Exception** : java.lang.NullPointerException java.io.File.<init>(File.java:277)

      Task failed

      ** Export End ** at 2019.06.10-14.38.55

       

      Stack trace:

      java.lang.NullPointerException

      at java.io.File.<init>(File.java:277)

      at oracle.dbtools.raptor.export.ExportGenerationOutputStream.closeCurrentStream(ExportGenerationOutputStream.java:537)

      at oracle.dbtools.raptor.export.ExportGenerationOutputStream.finished(ExportGenerationOutputStream.java:464)

      at oracle.dbtools.raptor.export.ExportAPI$1.doWork(ExportAPI.java:1446)

      at oracle.dbtools.raptor.export.ExportAPI$1.doWork(ExportAPI.java:1409)

      at oracle.dbtools.raptor.backgroundTask.RaptorTask.call(RaptorTask.java:199)

      at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      at oracle.dbtools.raptor.backgroundTask.RaptorTaskManager$RaptorFutureTask.run(RaptorTaskManager.java:702)

      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

      at java.util.concurrent.FutureTask.run(FutureTask.java:266)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

      at java.lang.Thread.run(Thread.java:748)

       

      Logging Page:

      Nothing

       

      I have tried saving to different locations and different drives with no success. I have also attempted changing the file name, and same problem. I have tried SQL Developer 18.4.0.376.1900 and 19.1.0.094.2042.

       

      I am only experiencing this with one query at the moment. I suspect it has to do with the where clause, which has 2500+ OR clauses for a certain condition (using IN has a limit of 1,000 items in the list), as commenting out that block allows me to export (which has more rows than the problematic query, so I don't think it's a row count issue).

       

      This is a blocker in me completing a work-related task, so any help would be appreciated.