1 Reply Latest reply on Jul 16, 2019 11:48 PM by Glen Conway

    19.1 - Worksheet stopped opening, possibly after a Windows update

    Glen Conway

      I just noticed that my worksheet no longer opens automatically upon opening a connection.  It had been working fine since I downloaded it 3 months ago.

       

      Same thing if I explicitly request a worksheet via the context menu (Open SQL Worksheet).

       

      In the Logging Page, I get:

      WorksheetOpenFailures.jpg

      I tried deleting my Roaming\SQL Developer\system19.1.0.094.2042 settings twice, once with migration from 18.4 and once without.  Nothing works.

      I also tried running SQL Developer as Administrator.  Nope.

       

      The only change to my system seems to be some Windows Updates:

      WorksheetOpenLastWindowsUpdates.jpg

       

      I haven't tried backing those out yet, but I will probably give it a try.  Also, Microsoft is warning that I should move from Windows 10 - 1803 to 1903.

       

      Usually weird things happened to others, but I guess it is my turn this time.  Any ideas?  And, especially, does anyone know what is going on at line 526 in

      null at oracle.dbtools.worksheet.editor.OpenWorksheetWizard.openNewTempWorksheet(OpenWorksheetWizard.java:526)

      Thanks!