3 Replies Latest reply on Jul 28, 2019 7:27 PM by Dude!

    How to disable the auto-inserted icons/images?

    mNem

      Can someone please suggest how to disable (or even a workaround) those images or icons from auto-inserted when the text/code has something like ( + ) or : ) or @?

       

      Thanks.

        • 1. Re: How to disable the auto-inserted icons/images?
          BluShadow

          There's no easy workaround.  Sometimes you can try and fool the editor by typing it with spaces and then removing the spaces etc. later. but that rarely works as it tends to re-parse the text when you save it anyway.

          The simplest way to avoid getting for your outer joins is to not use it.  That may sound flippant, but joins in SQL are best done in ANSI syntax rather than oracle specific syntax (in fact there are some thing you can do with ANSI syntax that you can't do with oracle syntax, such as outer join on more than one table, or include OR conditions etc.)

           

          So, instead of:

           

          select d.dname, e.ename

          from   dept d

                ,emp e

          where d.deptno = e.deptno(+)

           

          you would write:

           

          select d.dname, e.ename

          from   dept d

                left outer join emp e on d.deptno = e.deptno

           

          As for the other icons, you just have to put a side note with your text/code to explain what it should be.

           

          Edit: And no, don't ask me how my code above didn't convert the outer join automagically to a , it just didn't for some reason, perhaps because it was straight after the text and there was no space between the column name and the symbol.  Personally though, I'd use ANSI syntax.

          • 2. Re: How to disable the auto-inserted icons/images?
            Dude!

            The editor does not allow the user to turn off auto format options and this can be quite annoying.

             

            I suggest the following:

             

            Switch to the "advanced editor"

            Note: it's not available when you comment from your Inbox but when you "reply" after opening the thread.

            Choose Syntax Highlighting from the  >> menu.

             

            For example:

             

            (+)
            
            

             

            These and other annoying issues have already been mentioned several times in the past. Apparently on one is able to address these problems..

            • 3. Re: How to disable the auto-inserted icons/images?
              Dude!

              Some more info:

               

              https://community.jivesoftware.com/thread/279902

              https://docs.jivesoftware.com/cloud_int/comm_mgr/jive.help.core.mobile/admin/EmoticonFilter.html

               

              It will probably require an Oracle software admin or engineer to confirm what configuration options are available. I too run into this emoj stuff once in a while and find it irritating. Just an idea, maybe removing those .png's in the software might work.