3 Replies Latest reply on Aug 21, 2019 2:44 PM by kneuffer

    Credentials not working when creating Schema Baseline

    Suzanne_London

      Can anyone help me with this issue, can't find anything on KB.

       

      I'm trying to create a schema baseline and can't even get past connecting to a source db because following error is always returned:

       

      "Source Database - Could not connect to database. Make sure the database is up and preferred credentials (if set) are valid."

       

      I have both:

      1) set and thoroughly tested preferred normal credentials for the named database, in which case I don't get prompted for credentials, and

      2) tried without preferred credentials so I get prompted for credentials.

       

      In either case same error occurs.

       

      Before anyone suggests it, I have created a case with Oracle support but have had no progress on this seemingly simple issue after 5 months because after providing for a load of debugging output, the best someone could come up with is something to the effect of: "try setting every credential under the sun in case something magically works"

        • 1. Re: Credentials not working when creating Schema Baseline
          Suzanne_London

          Just realized I had previously created a question (this has gone on so long I completely forgot) and was asked at that point to check emoms trc file.  So I did that and see error:

           

          2019-07-31 07:43:31,484 [EMUI_07_43_31_/console/database/changemgr/capture/capture] ERROR job.ChangeMgrJob createTargetConnection.628 - InvalidArgumentException getting target DB connection

          oracle.sysman.emInternalSDK.db.conn.InvalidArgumentException: password must not be null or empty string.

                  at oracle.sysman.emInternalSDK.db.conn.DBConnectionUtil.validateDBUserCreds(DBConnectionUtil.java:1586)

                  at oracle.sysman.emInternalSDK.db.conn.DBConnectionUtil.getConnection(DBConnectionUtil.java:182)

           

          I'm still at a loss as to why this should be, can someone clarify EXACTLY what credentials should be used here.  Also, is there any bug which stops this from working with LDAP authenticated accounts?

          • 2. Re: Credentials not working when creating Schema Baseline
            Suzanne_London

            Scratch that question about LDAP, I just tested with plain password, same error occurred

            • 3. Re: Credentials not working when creating Schema Baseline
              kneuffer

              I am having the same issue.  My application is on a RAC and we are using OEM version 13.2.  There is a known bug concerning Named Credentials and RACs that was supposed to have been fixed in 13.2.  The bug document suggests creating Named Credentials with emcli as a work-around. 

               

              We are upgrading to 13.3 today.  Once that is complete, the OEM SA is going to try to create a Baseline with his account.  If it doesn't work, he's going to try creating a Named Credential with emcli and use that to create a Baseline.

               

              I'll let you know if we have any success.