9 Replies Latest reply on Aug 9, 2019 5:00 PM by nelsonjfr

    CPU Fan

    nelsonjfr

      Machine with Windows10 and SqlDeveloper  Version 19.1.0.094 Build 094.2042.

      Ever since I installed this version SqlDeveloper is causing my CPU Fan to go crazy for a minute at times longer when using the program.

      I do not have a dedicated GPU, but I think I am experiencing something similar to what is described here macOS discreet GPU usage .

      If I close the welcome screen or not use Instance Viewer, it does not happen.

       

      Is there any parameter I can set to stop this from happening?

      Will a future version fix it?

       

      Thanks

        • 1. Re: CPU Fan
          Glen Conway

          As thatJeffSmith-Oracle noted in one reply: "using JavaFX engages the GPU, it's not a bug, just how it works"

          And if there is no GPU, then the CPU must do the same work.  You say it "is causing my CPU Fan to go crazy for a minute at times longer", but that is not really very much of a problem.

           

          I personally find it much more of a problem looking at web pages that push out a lot of content on the Firefox or the Chrome browser.  Then the fan never stops!

           

          Edit:  Actually, I tried running the SQL Developer instance viewer after using the following to force my 19.1 sqldeveloper.exe to use the "Power saving" GPU rather than system default "High performance" GPU.

                   It seems to help:  https://www.tenforums.com/tutorials/103965-set-preferred-gpu-apps-windows-10-a.html 

          • 2. Re: CPU Fan
            nelsonjfr

            Will try that thanks.

            And the noise of the fan can be heard three offices down!

            • 3. Re: CPU Fan
              Matthias_H

              Are you sure this is working with SQL Developer? I tried it with the new SQL Developer 19.2 but when I run the Instance Viewer I see the CPU consuming almost 100%, and the GPU barely 5%. I don't see any difference between enabling or disabling it.

               

              Thanks

              Matthias

               

              Btw: this is on a laptop with Intel Core i5 processor and Windows 10 version 1803

              • 4. Re: CPU Fan
                thatJeffSmith-Oracle

                My intel core i5 has 6 cores, and my cpu is at 129% (out of 600%?) with instance viewer open using 19.2 and Java 12...but I don't have a GPU

                • 5. Re: CPU Fan
                  Glen Conway

                  Are you sure this is working with SQL Developer?

                  Sorry if I gave anyone false hope.  By saying "it seems to help", I gave switching to "Power saving" GPU an undeserved endorsement. 

                   

                  1) My laptop is an Intel Core i7-8550U (4 cores, 8 logical processors) with a SSD and 16 GB of RAM, about 18 months old.

                  2) My fan is either off, barely audible, or just a little noisy. 

                  3) When running Instance viewer (18.4 with jdk 1.8.0_221 or 19.2 with jdk jdk-11.0.4) my cpu trends between 15% - 23%

                  4) In this state the fan is barely audible / quiet.

                   

                  While peak cpu can be much higher when starting instance viewer, it settles down to that 15% - 23% range after a few seconds.  If the instance viewer or Welcome Page do not have the focus in the UI, then cpu usage rapidly falls to almost 0%.  I tend to keep the laptop plugged in as much as possible, so I am not bothered by the battery being drained, or too much heat, or too much noise.  I tend not to have instance viewer open much, but if I do and it does not have the focus, there is absolutely no issue.

                   

                  The behavior I just described holds true whether I use jdk 1.8 or jdk 11 with SQL Developer 19.2.  It also holds true whether I configure the 19.2 exe to "Power saving" or "High performance" GPU.  It holds true whether I specifically start SQL Developer 19.2  via the (right-click) context menu option "Run with graphics processor -> Integrated graphics (default)" or "Run with graphics processor -> High-performance NVIDIA processor".  And, of course, your comment was

                  I tried it with the new SQL Developer 19.2 but when I run the Instance Viewer I see the CPU consuming almost 100%, and the GPU barely 5%. I don't see any difference between enabling or disabling it.

                  and I must agree.  And, in fact, if I check Task Manager, it confuses me greatly since it does not show SQL Developer using the GPU at all:

                  Capture.JPG

                  • 6. Re: CPU Fan
                    nelsonjfr

                    Setting the GPU power settings did not work.

                    I closed the start page and the number of times the fan went berserk were reduced by 80%.

                    I have not had the time to measure CPU usage with instance viewer, but I know as soon as I open that the fan spins out of control.

                    • 7. Re: CPU Fan
                      Glen Conway

                      If using any of the JavaFX features (like Welcome page, Instance Viewer, Real Time SQL Monitory) cause that kind of severe fan reaction on your system, perhaps that could be an indication of some hardware issue / hardware driver bug.  Try looking  in Device Manager and update drivers for any graphics devices under "Display adapters" and any fans under "System devices".

                      • 8. Re: CPU Fan
                        thatJeffSmith-Oracle

                        Not a bad idea...

                        • 9. Re: CPU Fan
                          nelsonjfr

                          Well I finally opened the box and realized it was not using an onboard video but there was actually a graphic card in it.

                          Drivers are updated but it still happens.

                          So I am thinking I need to change the card if I want the noise to be reduced.

                          Thank you all for the help.