6 Replies Latest reply on Aug 8, 2019 11:32 PM by L. Fernigrini

    "Missing IN or OUT parameter at index ::1" error on SQL Developer 19.2

    L. Fernigrini

      Hi, while I was preparing some simple examples for a demo, I worked on Live SQL and everything worked fine with this query

       

       

      CREATE TABLE Producto (

            ID NUMBER(10) NOT NULL,

            Marca VARCHAR2(100) NOT NULL,

            Nombre VARCHAR2(100) NOT NULL,

            Precio NUMBER(10,4) NOT NULL,

            CONSTRAINT PK_Producto PRIMARY KEY (ID)

      );

      INSERT INTO Producto VALUES (1, 'Sony', 'TV LED 40"', 20000);

      INSERT INTO Producto VALUES (2, 'Philips', 'TV LED 32"', 15000 );

      INSERT INTO Producto VALUES (3, 'Motorola', 'Moto Z4', 25000);

       

      SELECT JSON_OBJECT('ID':id, 'Producto':nombre) AS json_data_new

      FROM Producto p;

       

       

       

      Then since I did not want to depend on internet connection for the demo, I downloaded the latest Developer Day VM from the site (https://www.oracle.com/technetwork/database/enterprise-edition/databaseappdev-vm-161299.html ) and also upgraded my local SQL Developer to version 19.2 (used the version with embedded JAVA). My computer runs Windows 10 Enterprise Edition.

       

      When running the same query from my local SQL Developer connected to the DB in the VM (using thin connection), I got the following error (here is in Spanish since my PC is on Spanish and SQL Developer uses the computer language by default):

       

      Does anyone found a similar situation? I suspect it is related to the JDBC driver but would like to know if someone had the same error, I was able to do the demo by running that query directly with SQL*Plus on the VM with no issues.