4 Replies Latest reply on Apr 15, 2020 9:19 PM by Simon Coter-Oracle

    Upgrade Ovirt KVM host

    3316730

      Hi there, can someone advise why the upgrade of KVM host will fail? Getting errors like this:

       

      Error: sos conflicts with vdsm-4.20.46-1.0.8.el7.x86_64

      Error: Package: vdsm-4.20.46-1.0.8.el7.x86_64 (ovirt-4.2)

       

      Thanks!

        • 1. Re: Upgrade Ovirt KVM host
          kkovachki

          This is a bug

          Also there is update on the SRPMS

          x86_64:

          vdsm-4.20.46-1.0.8.el7.x86_64.rpm

          vdsm-api-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-client-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-common-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-gluster-4.20.46-1.0.8.el7.x86_64.rpm

          vdsm-hook-allocate_net-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-boot_hostdev-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-checkimages-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-checkips-4.20.46-1.0.8.el7.x86_64.rpm

          vdsm-hook-cpuflags-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-diskunmap-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-ethtool-options-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-extnet-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-extra-ipv4-addrs-4.20.46-1.0.8.el7.x86_64.rpm

          vdsm-hook-fakevmstats-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-faqemu-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-fcoe-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-fileinject-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-floppy-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-httpsisoboot-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-ipv6-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-isolatedprivatevlan-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-localdisk-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-macbind-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-macspoof-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-nestedvt-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-noipspoof-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-numa-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-openstacknet-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-pincpu-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-promisc-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-qemucmdline-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-qos-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-scratchpad-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-smbios-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-spiceoptions-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-vhostmd-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-vmdisk-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-hook-vmfex-dev-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-http-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-jsonrpc-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-network-4.20.46-1.0.8.el7.x86_64.rpm

          vdsm-python-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-tests-4.20.46-1.0.8.el7.noarch.rpm

          vdsm-yajsonrpc-4.20.46-1.0.8.el7.noarch.rpm

          http://oss.oracle.com/ol7/SRPMS-updates/

          Bug

          https://linux.oracle.com/errata/ELBA-2019-4765.html

          • 2. Re: Upgrade Ovirt KVM host
            Kiran Rajendra-Oracle

            The workaround is as follows:

            # yum install yum-plugin-versionlock

            # yum versionlock sos

            # yum update -y

             

            The latest vdsm package (vdsm-4.20.46-1.0.8.el7.x86_64) is having fix for this issue.

             

            Note : sos package has to be downgraded (with "yum downgrade sos") until the release sos-3.6*.

            issue is sos-3.7 is not accepted by vdsm, downgrade is needed until the release sos-3.6* is available on system.

            # rpm -q --requires vdsm | grep sos

            sos < 3.7

            • 3. Re: Upgrade Ovirt KVM host
              Ian Hoogeboom

              The latest vdsm package (vdsm-4.20.46-1.0.8.el7.x86_64) is having fix for this issue.

              The latest version 'vdsm-4.20.46-1.0.8.el7.x86_64' is still having the issue:

               

              Error: sos conflicts with vdsm-4.20.46-1.0.8.el7.x86_64

              Error: Package: vdsm-4.20.46-1.0.8.el7.x86_64 (@ovirt-4.2)

                         Requires: sos < 3.7

              • 4. Re: Upgrade Ovirt KVM host
                Simon Coter-Oracle

                Best option to get this issue sorted out is now to upgrade to OLVM 4.3 release.