1 Reply Latest reply on Oct 9, 2019 3:01 PM by BobLilly

    How to increase Integration Broker timeout threshold

    JBabbit121

      We have a new Alert email notification process (EOEN_ALERT) enabled that uses the Service operation EOEN_MSG to publish email message to the email server. We are having issues with the email messages being published 5 times (4 duplications sent 20 minutes apart from each other) so we looked further at the Integration Broker queue EOEN_MSG_CHNL and noticed that the very last (newest) transaction will stay in a 'Working' status for 20 minutes, and then issue a Retry before it finishes processing. When this occurs the messages that already had been processed on the prior attempt are published again (hence the email duplication). It keeps performing retries until the Retry count reaches 6, and then the status goes to Timeout and the emails stop.

       

      Is there a way we can adjust (increase) any parameters for when the timeout occurs?  Thank you.

        • 1. Re: How to increase Integration Broker timeout threshold
          BobLilly

          The timeout and max retries are specified in the App Server configuration file. In this case I think it would be the ones under PSSUBHND_dflt, or possibly under PSPUBHND_dflt. However, these settings will have a global scope affecting all service operations so I wouldn't recommend changing them.

           

          For outbound operations you can change the delivery mode in the routing from Guaranteed to Best Effort to eliminate the retries, but in this case the routing is Local so it isn't an option.

           

          If you can recreate the problem in a non-production environment I would recommend enabling a PeopleCode trace to figure out why the operations are timing out. Depending on your tools version, there's also an app server setting described in the documentation under the SMTP Settings section called SMTPTimeToWaitForResult that may not be listed in the default app server config file. It says the default value for this setting is 10000 ms (10 seconds). You could try increasing it if you discover that the delay is on the mail server side, but 10 seconds is a long time and there could be a DNS or other network issue that needs to be addressed. You could also enable the SMTPTrace setting and see what it gives you (requires LogFence=5 as well).

           

          Regards,

          Bob