3 Replies Latest reply on Oct 10, 2019 2:28 AM by Beauty_and_dBest

    Cloning EBS 12.1.3

    Beauty_and_dBest

      EBS 12.1.3

      11g

      OL6

       

       

      Hi ALL,

       

      I am cloning our EBS PROD instance to  TEST, but I want my init.ora to be the same size exactly as PROD.

      We still use pfile.

      But my issue is the init.ora for test  is set to default small one

      I tried to copy the init.ora in PROD to TEST and update lots of parameters,

      but it seems corrupted and my APPS does not connect? even if the database start succesfully?

       

      Is there a way to copy the initPROD.ora   to initTEST.ora that will not corrupt the contents?

       

       

      Please help....

       

      Kind regards,

        • 1. Re: Cloning EBS 12.1.3
          Maaz Khan

          Hi Jc,

           

          Can you try sed command, below are few examples -

          1. if you want to change all values in your pfile from ebsprod to ebsdev

          sed "s#EBSPROD#EBSDEV#g" initEBSPROD.ora > initEBSDEV.ora

           

          2. If you want to replace directory structure -

          sed "s#/dbTier/oracle/EBSPROD/data#/dbTier/oracle/EBSDEV/data#g" initEBSPROD.ora > initEBSDEV.ora

           

          Regards,

          Maaz

          • 2. Re: Cloning EBS 12.1.3
            Beauty_and_dBest

            Thanks Maaz,

             

            What other paremeters do I need to change? Do I only need to run substitute the two commands?

             

            Actually, I tried to copy  initPROD.ora  to initTEST.ora

            Then I edit initTEST.ora and global substitute all occurrence of "PROD"  to "TEST", as well as the server hostname to target hostname.

            But it did not work?

             

             

            The target new Cloned instance has the following few default init.ora parameters which differs from the PROD settings:

             

            plsql_optimize_level     = 2              # Required 11i setting

            plsql_code_type          = INTERPRETED    # Default 11i setting

            plsql_native_library_dir = /u01/oracle/PROD/db/tech_st/11.1.0/plsql/nativelib

            plsql_native_library_subdir_count = 149

             

             

            But the source PROD instance  has this below ( the three (3) parameters were commented out,  and plsql_code_type changed to native?

             

            #plsql_optimize_level     = 2              # Required 11i setting

            plsql_code_type          = NATIVE          # Default 11i setting
            #plsql_code_type          = INTERPRETED    # Default 11i setting

            #plsql_native_library_dir = /u01/oracle/PROD/db/tech_st/11.1.0/plsql/nativelib

            #plsql_native_library_subdir_count = 149

             

             

            Does the above settings help improve performance or downgrade it?

             

            Please help....

             

             

            Kind regards

            • 3. Re: Cloning EBS 12.1.3
              Beauty_and_dBest

              Hi,

               

              After retrying, I can connect now.

              This is still using the same "replace global"  init.ora parameter.

              Maybe the first time which I can not login, there is glitch in the internet connection?

               

               

              Thanks ALL!