7 Replies Latest reply on Nov 25, 2019 6:17 PM by budachst

    Null pointer exception when trying to delete elements in repository.

    3426681

      Hi all,

       

      I have a really strange behaviour with a repository. It's actually an old repository which is the only repo left for some old pool that I want to delete (taking the last server out).

       

      - The repository, when looking at it through the GUI still says, that there is an ISO and a Virual Disk Image still on this repository.

      - When logging into the physical server the apropriate files are no longer there - it completly empty except for the default folder structure with ISOs, VirtualDisks,...

      - When trying to delete the elements in the repo it gives a null pointer exception: OVMAPI_6001E Exception invoking method (Method: com.oracle.ovm.mgr.rules.modules.api.virtual.RepositoryRules.deleteVirtualDiskPre, Args: [ProdRepo3, frank_vm_win10_2019]) - null [Wed Nov 20 16:18:45 CET 2019]

      - When trying to release ownership of the repository  it also gives a null pointer exception: OVMAPI_6001E Exception invoking method (Method: com.oracle.ovm.mgr.rules.modules.api.virtual.RepositoryRules.releaseOwnershipPre, Args: [ProdRepo3]) - null [Wed Nov 20 16:20:12 CET 2019]

      - I've also already tried giving him some fake files at the location he would expect for those object, but no difference, when trying to delete, still NPE.

      - When Itry to delete the pool it says it can't because it can't: OVMRU_000036E Cannot remove server: nodeA, from pool: ProdPool. There are still OCFS2 file systems: [0004fb0000050000290af1a0cd94c4d8], in the pool. [Wed Nov 20 16:37:54 CET 2019] (the OCFS2 filesystem ID is the filesystem of the repo in question), though it was able to unpresent/unmount the FS from the node.

      - I've also already tried to unmap the apropriate device from the Storage subsystem (so that the server can't see it anymore), rebooted the server (so that any old reference should be gone), but the error messages remains the same.

       

       

      Anyone an idea how I could remove these objects from the database, so that I can actually delete the repo and thenafter the pool ?

       

      Thanks for your help

       

      Frank