2 Replies Latest reply on Dec 7, 2019 4:24 AM by mNem

    Advanced editor duplicates a character

    mNem

      The advanced editor seems to auto replace on 1=1 to on 11=1 .

       

      The simplified code is something like ... (in one format)

       

      with t1 (a) as

      (

      select 'some xml stuff' from dual

      )

      , t2 (b) as

      (

      select 'something from node 01' from dual union all

      select 'something from node 02' from dual

      )

      select t1.*, t2.*

      from t1 left join t2

      on 1=1

      ;

       

      The faulty formatting ( >> / Syntax Highlighting / xml)

       

      with t1 (a) as 
      (
      select 'something' from dual
      )
      , t2 (b) as
      (
      select 'something 01' from dual union all
      select 'something 02' from dual
      )
      select t1.*, t2.* 
      from t1 left join t2
      on 1=1
      ;
      

       

       

      Yes, I did change it to 0=0 and it also gets modified to 00=0

       

      with t1 (a) as 
      (
      select 'something' from dual
      )
      , t2 (b) as
      (
      select 'something 01' from dual union all
      select 'something 02' from dual
      )
      select t1.*, t2.* 
      from t1 left join t2
      on 0=0
      ;
      
      

       

      If I use another format (>> / Syntax Highlighting / SQL)

       

      with t1 (a) as 
      (
      select 'something' from dual
      )
      , t2 (b) as
      (
      select 'something 01' from dual union all
      select 'something 02' from dual
      )
      select t1.*, t2.* 
      from t1 left join t2
      on 0=0
      ;