1 Reply Latest reply on Dec 13, 2019 12:47 PM by Mohammad Shaddad

    Enable ords https on tomcat

    Mohammad Shaddad

      Hi All

      Kindly, I am trying to configure HTTPS on ords which is deployed on tomcat but it's not working, please help

       

      ords: 19.2

      linux server

       

      This is the steps which I follow:

       

      1-create keystore file using the following command

       

      /u01/tomcat/java/jdk1.8.0_171/jre/bin/keytool -genkey -alias tomcat -keyalg RSA -keystore /u01/tomcat/apache-tomcat-9.0.8/webapps/keystore

      • password
      • mohamed shaddad
      • extra
      • extra
      • khobar
      • eastern
      • SA

       

      rename the keystore file to .keystore

       

      2- adding the following in tomcat config file server.xml

       

       

       

      3- restart tomcat

          <!-- Define an HTTP/1.1 Connector on port 8443, JSSE NIO implementation -->
          <Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
                 sslImplementationName="org.apache.tomcat.util.net.jsse.JSSEImplementation"
                  />
          <!-- Define an HTTP/1.1 Connector on port 8443, JSSE NIO2 implementation -->
          <Connector port="8443" protocol="org.apache.coyote.http11.Http11Nio2Protocol"
                 sslImplementationName="org.apache.tomcat.util.net.jsse.JSSEImplementation"
                  />
          <!-- Define an SSL Coyote HTTP/1.1 Connector on port 8443 -->
          <Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
                 maxThreads="200" SSLEnabled="true"
                 scheme="https" secure="true"
                 keystoreFile="/u01/tomcat/apache-tomcat-9.0.8/webapps/.keystore" keystorePass="password"
                 clientAuth="false" sslProtocol="TLS"/>
      

       

      4-try to open my page using https and port 8443 but it's not opening

       

      Note: I can see the error in attached log file

       

      Thanks ...