4 Replies Latest reply on Jan 23, 2020 2:53 PM by Michael.R.Taylor-Oracle

    zmq.backend.cython.socket.Socket.bind error trying to install DynUpdater

    user7525195

      Hey everyone, I am having a hard time getting DynUpdater installed on my new PC.  I have been using DynUpdater (official from dyn's site) for years on my old PC without any problems to speak of.

       

      However, this past week, I built a new PC, uninstalled DynUpdater from my old PC, and downloaded the latest version of DynUpdater from the site.  Upon attempting install, the progress bar gets to about 60% or 70% and then just hangs.  It eventually fails, but I've tried to do some troubleshooting as to why it is failing.  The service that installation is trying to create is created, but upon startup, it is throwing this error into the Event log:

       

      The instance's SvcRun() method failed

      Traceback (most recent call last):

        File "/win32serviceutil.py", line 835, in SvcRun

        File "/lib\daemon\windows.py", line 230, in SvcDoRun

        File "/lib\daemon\windows.py", line 281, in main

        File "/lib\daemon\common.py", line 158, in start_zmq

        File "zmq/backend/cython/socket.pyx", line 487, in zmq.backend.cython.socket.Socket.bind (zmq\backend\cython\socket.c:5156)

        File "zmq/backend/cython/checkrc.pxd", line 25, in zmq.backend.cython.checkrc._check_rc (zmq\backend\cython\socket.c:7535)

      zmq.error.ZMQError: Address in use

      %2: %3

       

      I have tried searching Dyn's forums as well as the internet in general, but I haven't found a resolution.  I am admin on the box, so I don't believe it is a permissions issue and nothing else about the build of the PC, the setup of Windows, or the installation of any other software has given me any trouble, so I believe this problem is isolated to this one installation.

       

      Any help you could provide would be greatly appreciated.